summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 22 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8c06d142f8c8..c7f5bbaa268e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,31 @@
-# Maintainer: Samuel Dudík <dudik at tutanota dot com>
-_pkgname=herbe
-pkgname=$_pkgname-git
-pkgver=1
-pkgrel=1
-arch=(any)
+# Maintainer: Lancia Greggori <lanciagreggori@gmail.com>
+
+pkgname=herbe-git
+pkgver=1.0.0.r10.gdec89e4
+pkgrel=3
+pkgdesc='Daemon-less notifications without D-Bus'
+arch=('x86_64')
+url='https://github.com/dudik/herbe'
license=('MIT')
+depends=('libx11' 'libxft')
makedepends=('git')
-url="https://github.com/dudik/$_pkgname"
-source=("git+https://github.com/dudik/$_pkgname.git")
+provides=("${pkgname%-*}")
+conflicts=("${pkgname%-*}")
+source=("${pkgname}::git+${url}")
md5sums=('SKIP')
-prepare() {
- cd $_pkgname
- if [ -f "$srcdir/config.h" ]; then
- cp -f "$srcdir/config.h" config.h
- fi
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-build () {
- cd "$_pkgname"
- make
+build() {
+ cd "$pkgname"
+ make clean all
}
-package () {
- cd "$_pkgname"
- mkdir -p "$pkgdir/usr/local/bin"
- cp $_pkgname "$pkgdir/usr/local/bin/"
+package() {
+ cd "$pkgname"
+ make PREFIX=/usr DESTDIR="$pkgdir/" install
+ install -D -m 644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}