summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 6 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a82ff9f3f806..3c23c64064f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
pkgname=highfive
_pkgname=HighFive
pkgver=2.9.0
-pkgrel=1
+pkgrel=2
pkgdesc="Header-only C++ HDF5 interface"
arch=('any')
url='https://github.com/BlueBrain/HighFive'
license=('Boost')
depends=('boost' 'hdf5' 'eigen')
-makedepends=('cmake')
+makedepends=('cmake' 'catch2')
source=(https://github.com/BlueBrain/$_pkgname/archive/v$pkgver.tar.gz)
md5sums=('2d63bbc518362e5b928f19f122504f05')
@@ -22,19 +22,14 @@ build() {
cd build-$pkgver
cmake -DCMAKE_INSTALL_PREFIX=/usr -DHIGHFIVE_EXAMPLES=OFF \
-DHIGHFIVE_USE_EIGEN=ON -DCMAKE_BUILD_TYPE=Release \
- -DHIGHFIVE_UNIT_TESTS=OFF \
../$_pkgname-$pkgver
make
}
-# Skip check() for now due to conflicting Catch2 versions. HighFive
-# 2.7.0 requires Catch2 v3 for unit tests, but the main Arch repos
-# provide Catch2 v2.
-
-# check() {
-# cd build-$pkgver
-# make test
-# }
+check() {
+ cd build-$pkgver
+ make test
+}
package() {
cd build-$pkgver