summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 13 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 535baa2cd5b0..79ad1ab6ec77 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ arch=('any')
url="https://github.com/horenjs/horen"
license=('MIT')
conflicts=("${pkgname%-git}")
-provides=("${pkgname%-git}")
+provides=("${pkgname%-git}-${pkgver%.r*}")
depends=(
"electron${_electronversion}"
)
@@ -25,7 +25,7 @@ source=(
"${pkgname%-git}.sh"
)
sha256sums=('SKIP'
- 'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
+ '41b6d61dffef064762b3eec3dfeca7a3e1f57cbcb6dce9a6940c06797a0eae9d')
pkgver() {
cd "${srcdir}/${pkgname//-/.}"
git describe --long --tags --exclude='*[a-z][a-z]*' | sed -E 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
@@ -34,23 +34,25 @@ build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-git}|g" \
-e "s|@runname@|app|g" \
+ -e "s|@cfgdirname@|${_pkgname}|g" \
+ -e "s|@options@|env ELECTRON_OZONE_PLATFORM_HINT=auto|g" \
-i "${srcdir}/${pkgname%-git}.sh"
- gendesk -q -f -n --categories="AudioVideo" --name="${pkgname%-git}" --exec="${pkgname%-git} %U"
+ gendesk -q -f -n --pkgname="${pkgname%-git}" --categories="AudioVideo" --name="${pkgname%-git}" --exec="${pkgname%-git} %U"
cd "${srcdir}/${pkgname//-/.}"
export npm_config_build_from_source=true
export ELECTRON_SKIP_BINARY_DOWNLOAD=1
- export SYSTEM_ELECTRON_VERSION="$(electron${_electronversion} -v | sed 's/v//g')"
- export npm_config_target="${SYSTEM_ELECTRON_VERSION}"
- export ELECTRONVERSION="${_electronversion}"
- export npm_config_disturl=https://electronjs.org/headers
+ #export SYSTEM_ELECTRON_VERSION="$(electron${_electronversion} -v | sed 's/v//g')"
+ #export npm_config_target="${SYSTEM_ELECTRON_VERSION}"
+ #export ELECTRONVERSION="${_electronversion}"
HOME="${srcdir}/.electron-gyp"
pnpm config set store-dir "${srcdir}/.pnpm_store"
pnpm config set cache-dir "${srcdir}/.pnpm_cache"
pnpm config set link-workspace-packages true
- if [ `curl ifconfig.co/country` = "China" ];then
- echo 'registry="https://registry.npmmirror.com/"' >> .npmrc
- echo 'electron_mirror="https://registry.npmmirror.com/-/binary/electron/"' >> .npmrc
- echo 'electron_builder_binaries_mirror="https://registry.npmmirror.com/-/binary/electron-builder-binaries/"' >> .npmrc
+ if [ `curl -s ipinfo.io/country | grep CN | wc -l ` -ge 1 ];then
+ export npm_config_registry=https://registry.npmmirror.com
+ export npm_config_disturl=https://registry.npmmirror.com/-/binary/node/
+ export npm_config_electron_mirror=https://registry.npmmirror.com/-/binary/electron/
+ export npm_config_electron_builder_binaries_mirror=https://registry.npmmirror.com/-/binary/electron-builder-binaries/
else
echo "Your network is OK."
fi