summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD78
1 files changed, 41 insertions, 37 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a2c8c3a39935..381b01e3be8b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,63 +12,67 @@
# See the License for the specific language governing permissions and
# limitations under the License.
-# Maintainer: Aleksey Filippov <sarum9in@gmail.com>
+# Maintainer: David Wu <xdavidwuph@gmail.com>
+# Contributor: Lisa White <lisa.rsfp+dev@gmail.com>
+# Contributor: Aleksey Filippov <sarum9in@gmail.com>
# Contributor: Adrian Perez de Castro <aperez@igalia.com>
# Contributor: Lubosz Sarnecki <lubosz@gmail.com>
pkgname=hotdoc
-pkgver=0.8.103
-pkgrel=1
-epoch=
-pkgdesc="HotDoc: the tastiest API documentation system"
-arch=('any')
-url="https://github.com/hotdoc/hotdoc"
-license=('LGPL2')
-groups=()
+pkgver=0.12.2
+pkgrel=2
+pkgdesc='The tastiest API documentation system'
+arch=('x86_64') # parsers are built into native libraries
+url='https://github.com/hotdoc/hotdoc'
+license=('LGPL2.1')
+_xdgver=4.0.1
depends=(
+ 'json-glib'
+ 'clang'
+ 'llvm'
'python'
- 'python-cchardet'
- 'python-dbus-deviation'
- 'python-decorator'
+ 'python-yaml'
'python-lxml'
- 'python-networkx-1.11'
- 'python-pkgconfig-1.1.0'
'python-schema'
- 'python-setuptools'
- 'python-sqlalchemy'
+ 'python-appdirs'
+ 'python-wheezy-0.1.167'
'python-toposort'
- 'python-wheezy'
- 'python-yaml'
+ 'python-dbus-deviation'
+ 'python-pkgconfig-1.1.0'
+ 'python-cchardet'
+ 'python-networkx-1.11'
+ 'python-setuptools' # needed by hotdoc/utils/utils.py
)
makedepends=(
- 'npm'
'cmake'
'flex'
+ 'git'
+ 'npm'
+)
+# upstream tarball does not contain submodules or their revision info
+source=(
+ "git+https://github.com/${pkgname}/${pkgname}.git#tag=${pkgver}"
+ 'xdg-path.patch'
+ "https://github.com/srstevenson/xdg/archive/${_xdgver}.tar.gz"
)
-checkdepends=()
-optdepends=()
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=()
-install=
-changelog=
-source=("git+https://github.com/${pkgname}/${pkgname}.git#tag=${pkgver}")
-noextract=()
-sha256sums=('SKIP')
-validpgpkeys=()
+sha256sums=('SKIP'
+ 'c29c62073f0ffe03c8975a28855a42cf96c40085ff53d14303f832269c0d7d7c'
+ 'dfa8c94c29980faa6f67199c305b3e1de0f5aba48a0636d3a2aeccf0e0a662b7')
prepare() {
- cd "$pkgname"
- sed -r 's|print (".*\])|print (\1)|' -i hotdoc/hotdoc_dep_printer.py
+ cd "${pkgname}"
+ patch -p1 -i ../xdg-path.patch
+ mkdir -p hotdoc/xdg
+ cp "../xdg-${_xdgver}/src/xdg/__init__.py" hotdoc/xdg
}
build() {
- cd "$pkgname"
+ cd "${pkgname}"
python setup.py build
}
package() {
- cd "$pkgname"
- python setup.py install --root="$pkgdir/" --optimize=1
+ cd "${pkgname}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+ install -Dm644 "../xdg-${_xdgver}/LICENCE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENCE.xdg"
}