summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD78
1 files changed, 39 insertions, 39 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0e32cad44d9f..5ae0e210ecbc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,67 +1,67 @@
-# Maintainer: Chris Severance aur.severach aATt spamgourmet dott com
+# Maintainer: Sergey Kolesov <cucullus at mail dot ru>
+# Contributor: Chris Severance <aur.severach aATt spamgourmet dott com>
# Contributor: Joan Figueras <ffigue at gmail dot com>
# Contributor: megadriver <megadriver at gmx dot com>
# Based on hplip from [extra]
pkgname='hplip-minimal'
-pkgver=3.20.3
+pkgver=3.20.6
pkgrel=1
-pkgdesc='The HP printer drivers, and not much else'
-arch=('i686' 'x86_64' 'armv6h')
-url="https://hplipopensource.com"
+pkgdesc='HPLIP lite build (print and scan drivers only)'
+arch=('x86_64')
+url='https://developers.hp.com/hp-linux-imaging-and-printing/'
license=('GPL2' 'custom')
-depends=('python-dbus' 'python-distro' 'ghostscript>=8.64-6' 'libidn' 'libjpeg-turbo')
-makedepends=('cups' 'libusb')
-optdepends=(
- 'cups: for printing support'
- 'libusb: for advanced usb support'
-)
+depends=('foomatic-db-engine' 'libusb' 'ghostscript' 'libjpeg-turbo')
conflicts=('hplip')
+provides=('hplip')
+backup=('etc/hp/hplip.conf' 'etc/sane.d/dll.d/hpaio')
options=('!docs')
-source=("https://downloads.sourceforge.net/hplip/hplip-${pkgver}.tar.gz")
-md5sums=('f3b981187aa7cceda13783092c05efe8')
-sha256sums=('41097ec52af5cce51ec7b0200d9f9ec82649b58ae7105259e82130e9cf63066a')
-
-prepare() {
- cd "hplip-${pkgver}"
-}
+source=("https://downloads.sourceforge.net/hplip/hplip-${pkgver}.tar.gz"
+ 0025-Remove-all-ImageProcessor-functionality-which-is-clo.patch
+ hplip-revert-plugins.patch)
+md5sums=('89a596bac1a3e7df88be67b16a601a98'
+ 'a9c230a3a6ca8f336d5a12b099ae834f'
+ 'c199d694f544ac16088b4f8fd663b333')
+sha256sums=('c64b2d334348010a9911f4feb075b2aa669047e7adb86c72d4a6ee7d392a7c20'
+ '5b7c19487f6e4def978b58aa8686249f234d4f64e1fb2444c602ea16716477dd'
+ '327180688a945fde59d1e0b399877c92657f4e674cc6c21a2e5fd5b6460e922a')
+validpgpkeys=('4ABA2F66DBD5A95894910E0673D770CDA59047B9') # HPLIP (HP Linux Imaging and Printing) <hplip@hp.com>
+# Build instructions: https://developers.hp.com/hp-linux-imaging-and-printing/install/manual/distros/other
build() {
cd "hplip-${pkgver}"
- AUTOMAKE='automake --foreign' \
- autoreconf --force --install
- export CFLAGS+=" $(python3-config --includes)" # Fix build with python 3.8
+ # remove binary blob libImageProcessor and all linking - FS#59681
+ patch -Np1 -i "${srcdir}"/0025-Remove-all-ImageProcessor-functionality-which-is-clo.patch
+
+ # why do they disable the plugins for almost all printers??? - FS#67119
+ patch -Np1 -i ../hplip-revert-plugins.patch
+
+ # Configure options:
+ # https://developers.hp.com/hp-linux-imaging-and-printing/install/manual/configure
+ # ./configure -h
./configure --prefix=/usr \
- --disable-qt5 \
- --disable-qt4 \
- --enable-new-hpcups \
- --disable-cups-drv-install \
- --enable-pp-build \
+ --enable-lite-build \
--disable-doc-build \
- --disable-dbus-build \
- --disable-network-build \
- --disable-scan-build \
- --disable-fax-build \
- --disable-foomatic-rip-hplip-install \
- --enable-foomatic-ppd-install \
- --enable-cups-ppd-install
- make -s -j1
+ --disable-fax-build
+ #--disable-scan-build \
+ #--disable-gui-build
+
+ make
}
package() {
cd "hplip-${pkgver}"
- make -j1 DESTDIR="${pkgdir}/" install
+ make DESTDIR="${pkgdir}/" install
# remove config provided by sane and autostart of hp-daemon
- rm -rf "${pkgdir}"/etc/{sane.d,xdg}
+ rm -rf "$pkgdir"/etc/{sane.d,xdg}
+ install -dm755 "${pkgdir}"/etc/sane.d/dll.d
+ echo hpaio > "${pkgdir}"/etc/sane.d/dll.d/hpaio
# remove HAL .fdi file because HAL is no longer used
rm -vrf "${pkgdir}"/usr/share/hal
- # remove rc script
- rm -vrf "${pkgdir}"/etc/init.d
-
# add mixed license file
install -Dt "${pkgdir}"/usr/share/licenses/${pkgname} -m644 COPYING
}