summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2a9bd75bf06a..6c1806dd0885 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=hugin-messenger
_pkgname="Hugin Messenger"
-pkgver=0.4.0
+pkgver=0.5.0
_electronversion=19
_nodeversion=16
pkgrel=4
@@ -25,7 +25,7 @@ source=(
"${pkgname}.git::git+${_ghurl}#tag=v${pkgver}"
"${pkgname}.sh"
)
-sha256sums=('2f8feb2c8f2f84476ec2c7630b5d45cd49739e621730a8a02872e88ae27b735a'
+sha256sums=('SKIP'
'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
_ensure_local_nvm() {
export NVM_DIR="${srcdir}/.nvm"
@@ -51,9 +51,9 @@ build() {
export npm_config_disturl=https://electronjs.org/headers
HOME="${srcdir}/.electron-gyp"
if [ `curl -s ipinfo.io/country | grep CN | wc -l ` -ge 1 ];then
- echo 'registry="https://registry.npmmirror.com/"' >> .npmrc
- echo 'electron_mirror="https://registry.npmmirror.com/-/binary/electron/"' >> .npmrc
- echo 'electron_builder_binaries_mirror="https://registry.npmmirror.com/-/binary/electron-builder-binaries/"' >> .npmrc
+ export npm_config_registry=https://registry.npmmirror.com
+ export npm_config_electron_mirror=https://registry.npmmirror.com/-/binary/electron/
+ export npm_config_electron_builder_binaries_mirror=https://registry.npmmirror.com/-/binary/electron-builder-binaries/
else
echo "Your network is OK."
fi