summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 54f32a55725e..05d84c62f730 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,14 +9,17 @@ url="https://github.com/acrisci/$pkgname"
license=('BSD')
depends=('python')
makedepends=('python-setuptools')
-provides=("$pkgname")
-conflicts=("$pkgname-git")
source=("$pkgname-$pkgver.tar.gz::https://github.com/acrisci/$pkgname/archive/v$pkgver.tar.gz")
sha256sums=('8136db291f004992ef521cf77e9215e37974a768089601db18e642ac01412ca7')
+build() {
+ cd "$pkgname-$pkgver"
+ python setup.py build
+}
+
package() {
- cd "$srcdir/$pkgname-$pkgver"
- python setup.py install --root="${pkgdir}" --optimize=1
+ cd "$pkgname-$pkgver"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE
}