summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e397b29efa16..a667982babc4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=i3lock-blur
pkgver=2.10
-pkgrel=2
+pkgrel=3
pkgdesc="An improved screenlocker based upon XCB and PAM with background blurring filter"
arch=('x86_64')
url="http://github.com/karulont/i3lock-blur/"
@@ -12,11 +12,11 @@ conflicts=('i3lock')
depends=('xcb-util-image' 'libev' 'cairo' 'libxkbcommon-x11' 'pam')
options=('docs')
backup=("etc/pam.d/i3lock")
-source=("https://github.com/karulont/$pkgname/archive/$pkgver.tar.gz")
-sha512sums=('3b6eeff9dd839b66263098be50c23cb878ae9472ce05e4058434173446cc9309cdae04108d599f161b7b7185b526c888c9045d3fba1c12d915f5eb87afc6803c')
+source=("git+https://github.com/karulont/$pkgname/#tag=$pkgver")
+sha512sums=("SKIP")
build() {
- cd "${srcdir}/$pkgname-$pkgver"
+ cd "${srcdir}/$pkgname"
# Fix ticket FS#31544, sed line taken from gentoo
sed -i -e 's:login:system-auth:' pam/i3lock
@@ -27,7 +27,7 @@ build() {
}
package() {
- cd "${srcdir}/$pkgname-$pkgver"
+ cd "${srcdir}/$pkgname"
make install
install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
}