summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 15 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 631910cf269d..ed38bca9592f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,31 +2,37 @@
# Contributor: Helder Bertoldo <helder.bertoldo@gmail.com>
pkgname=iconoscope-git
-pkgver=0.9.3.r6.g03dada1
-pkgrel=1
+pkgver=0.9.9.r0.ge4dade8
+pkgrel=2
pkgdesc="Explore the system's icon theme database written in Vala designed for Pantheon Shell"
-arch=(any)
+arch=(x86_64)
url="https://github.com/santileortiz/Iconoscope"
license=(GPL3)
-depends=(libgranite.so python)
-makedepends=(git vala)
+depends=(gtk3)
+makedepends=(git python)
provides=(iconoscope)
conflicts=(iconoscope)
source=("iconoscope::git+${url}.git")
md5sums=('SKIP')
+prepare() {
+ # Add LDFLAGS
+ sed -i.bak "s/-lm/& ${LDFLAGS}/" "${pkgname%-git}/pymk.py"
+}
+
pkgver() {
- cd ${pkgname/-git/}
+ cd "${pkgname%-git}"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd ${pkgname/-git/}
+ cd "${pkgname%-git}"
./pymk.py iconoscope
}
package() {
- cd ${pkgname/-git/}
- ./pymk.py install --install_completions --destdir ${pkgdir}/
+ cd "${pkgname%-git}"
+ ./pymk.py install --install_completions --destdir "${pkgdir}/usr/"
+ ln -s /usr/bin/com.github.santileortiz.iconoscope "$pkgdir/usr/bin/iconoscope"
}