summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD65
1 files changed, 32 insertions, 33 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9c5032a96a27..15f312a0e85b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,30 +8,32 @@
# NOTE : This PKGBUILD is a copy of https://aur.archlinux.org/packages/imhex (maintained by KokaKiwi) with trivial modifications to fetch the latest commit.
pkgname=imhex-git
-pkgver=1.28.0.r73.gb0028b0e
+pkgver=1.31.0.r53.g5a71cc2d
pkgrel=1
pkgdesc='A Hex Editor for Reverse Engineers, Programmers and people that value their eye sight when working at 3 AM'
url='https://imhex.werwolv.net'
license=('GPL2')
arch=('x86_64')
-depends=('glfw' 'mbedtls' 'libssh2' 'curl' 'dbus'
+depends=('glfw' 'mbedtls' 'curl' 'dbus'
'freetype2' 'file' 'hicolor-icon-theme' 'xdg-desktop-portal'
'fmt' 'yara')
-makedepends=('git' 'cmake' 'llvm' 'nlohmann-json' 'librsvg' 'python')
-optdepends=(
- 'imhex-patterns-git: ImHex base patterns'
-)
-provides=(imhex)
-conflicts=(imhex)
+makedepends=('git' 'cmake'
+ 'llvm' 'nlohmann-json' 'librsvg'
+ 'python' 'cli11' 'dotnet-runtime')
+optdepends=('dotnet-runtime: support for .NET scripts')
+provides=('imhex' 'imhex-patterns')
+conflicts=('imhex' 'imhex-patterns-git')
source=("$pkgname::git+https://github.com/WerWolv/ImHex.git"
"nativefiledialog::git+https://github.com/btzy/nativefiledialog-extended.git"
"xdgpp::git+https://git.sr.ht/~danyspin97/xdgpp"
"libromfs::git+https://github.com/WerWolv/libromfs"
- "capstone::git+https://github.com/capstone-engine/capstone#branch=next"
+ "capstone::git+https://github.com/capstone-engine/capstone"
"libwolv::git+https://github.com/WerWolv/libwolv"
"pattern_language::git+https://github.com/WerWolv/PatternLanguage"
- 0001-makepkg-Fix-compiler-check.patch
- pl-0001-Use-C-23-standard.patch)
+ "imhex-patterns::git+https://github.com/WerWolv/ImHex-Patterns"
+ 0001-fix-cmake-Fix-when-multiple-.NET-packages-are-instal.patch
+ pl-0001-Use-C-23-standard.patch
+ pl-0002-makepkg-Remove-extraneous-compiler-flags.patch)
sha256sums=('SKIP'
'SKIP'
'SKIP'
@@ -39,8 +41,10 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- '43bdbbb6edf567201fa52f1c695f77fea9a27dd5c62de615ef74d64a5e676a98'
- '4c3e667d40eabe2a5ea724125c69f73bcb6774c01db9ad97bc6b633e1c284fc5')
+ 'SKIP'
+ '6db78e5899e4ed3eb9170cb30f321706e8f8c7531b38ebf43a1e6595e6f9fc18'
+ '9fad69a15f24d932353c1500a885640031699265dcced403d2c8e97e581274e3'
+ '1d45242b1090daeec4b028e64598b678a2099af4ec82ab71040082c24520f314')
b2sums=('SKIP'
'SKIP'
'SKIP'
@@ -48,8 +52,10 @@ b2sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- '99e8c5fb5dc0ad07039731c3245bec097de25e675be0f5c52c799738d794ee26df6506adf34fac42663dd39f1c84e7e1675aac5b2f47ef4f2d5ebb903ad4b3a3'
- 'ca3779e974709fa15e55255973eb2ff34fb21251c9f8b00c5b2efcfb175add34b503063984589c8d716b650a9543aa19dc2185b2f531ab8d4363635724114199')
+ 'SKIP'
+ 'd393cc7a6aa26fabac6ede2e435b6df1a334c74ba981af902bcfbb77841f89dba2f110c7e025ef20a808d10fda4865c7d1ed28a39debccb1e1f797765c7bb1ee'
+ 'd9967d5d82b3457fe3065dd3aa69887a4f07d2c74afd686250065bf438677e1b26801c9d2b5795003b22c1224c4447864559248a29bfd34a9af2bb637bc1d515'
+ '4b38b83a9c70a05f119e2d7704ca0721ac755dda05f1f23f81e5c2d41751ea2db8212b537db133d5ab75eee7c858f103ca5825ab182b3b53c35e59278fbed527')
options=(!lto !strip)
pkgver() {
@@ -64,7 +70,7 @@ prepare() {
for name in nativefiledialog xdgpp libromfs capstone libwolv pattern_language; do
git config submodule.lib/external/$name.url "$srcdir/$name"
done
- for name in fmt curl yara/yara; do
+ for name in fmt yara/yara; do
git config --remove-section submodule.lib/external/$name
done
git -c protocol.file.allow=always submodule update
@@ -77,10 +83,11 @@ prepare() {
submodule update
git apply \
- "$srcdir/0001-makepkg-Fix-compiler-check.patch"
+ "$srcdir/0001-fix-cmake-Fix-when-multiple-.NET-packages-are-instal.patch"
git -C lib/external/pattern_language apply \
- "$srcdir/pl-0001-Use-C-23-standard.patch"
+ "$srcdir/pl-0001-Use-C-23-standard.patch" \
+ "$srcdir/pl-0002-makepkg-Remove-extraneous-compiler-flags.patch"
}
build() {
@@ -94,32 +101,27 @@ build() {
-D IMHEX_OFFLINE_BUILD=ON \
-D IMHEX_IGNORE_BAD_CLONE=ON \
-D IMHEX_STRIP_RELEASE=OFF \
+ -D IMHEX_STRICT_WARNINGS=OFF \
+ -D IMHEX_BUNDLE_DOTNET=OFF \
-D USE_SYSTEM_LLVM=ON \
-D USE_SYSTEM_YARA=ON \
-D USE_SYSTEM_FMT=ON \
- -D USE_SYSTEM_CURL=ON \
-D USE_SYSTEM_NLOHMANN_JSON=ON \
-D USE_SYSTEM_CAPSTONE=OFF \
- -D LIBPL_ENABLE_CLI=OFF
+ -D IMHEX_VERSION="$pkgver"
cmake --build build
}
package() {
- # Executable
- install -Dm0755 build/imhex "$pkgdir/usr/bin/imhex"
-
- # Shared lib and plugins
- install -Dm0755 -t "$pkgdir/usr/lib" build/lib/libimhex/libimhex.so
-
- for plugin in builtin; do
- install -Dm0755 -t "$pkgdir/usr/lib/imhex/plugins" "build/plugins/$plugin.hexplug"
- done
+ DESTDIR="$pkgdir" cmake --install build
+ # Patterns
install -dm0755 "$pkgdir/usr/share/imhex"
+ cp -r -t "$pkgdir/usr/share/imhex" \
+ "$srcdir/imhex-patterns"/{constants,encodings,includes,magic,patterns,themes,tips}
# Desktop file(s)
- install -Dm0644 -t "$pkgdir/usr/share/applications" "$pkgname/dist/imhex.desktop"
install -Dm0644 "$pkgname/resources/icon.svg" "$pkgdir/usr/share/icons/hicolor/scalable/apps/imhex.svg"
for size in 32 48 64 128 256; do
install -dm0755 "$pkgdir/usr/share/icons/hicolor/${size}x${size}/apps"
@@ -127,9 +129,6 @@ package() {
"$pkgname/resources/icon.svg"
done
- # License
- install -Dm0644 "$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
-
# Documentation
install -Dm0644 -t "$pkgdir/usr/share/doc/$pkgname" \
"$pkgname/README.md"