summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 26c2c86cf02b..3f685c417654 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,18 @@
_pkgname=ir-lv2
pkgname="${_pkgname}-git"
-pkgver=1.3.2.r17.af1f8ab
-pkgrel=3
+pkgver=1.3.2.r20.a523bba
+pkgrel=1
pkgdesc="Real-time signal convolver esp. suited for impulse response reverb effects"
arch=('i686' 'x86_64')
-url="https://github.com/Anchakor/ir.lv2"
-license=('GPL')
+url="http://tomszilagyi.github.io/plugins/ir.lv2/"
+license=('GPL2')
depends=('gtk2>=2.16' 'libsamplerate' 'zita-convolver')
provides=('ir.lv2' "${_pkgname}" 'lv2-ir-git')
conflicts=('ir.lv2' "${_pkgname}" 'lv2-ir' 'lv2-ir-git')
groups=('lv2-plugins')
makedepends=('git' 'lv2')
-source=("${_pkgname}::git+https://github.com/Anchakor/ir.lv2.git")
+source=("${_pkgname}::git+https://github.com/tomszilagyi/ir.lv2")
md5sums=('SKIP')
changelog=ChangeLog
@@ -25,12 +25,12 @@ pkgver() {
echo ${version#version}.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)
}
-
build() {
cd "${srcdir}/${_pkgname}"
- make $MAKEFLAGS
- make convert4chan $MAKEFLAGS
+ export CPPFLAGS="$CXXFLAGS -Wno-parentheses"
+ make
+ make convert4chan
}
package() {
@@ -38,7 +38,7 @@ package() {
make PREFIX="$pkgdir/usr" install
install -Dm755 convert4chan "$pkgdir/usr/bin/convert4chan"
- install -Dm644 README "${pkgdir}"/usr/share/doc/$pkgname/README
+ install -Dm644 README.md sshot.png -t "${pkgdir}"/usr/share/doc/$pkgname
}
# vim:set ts=2 sw=2 et: