summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 9 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index eef89e2177ab..5614e399ed90 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,6 @@
-# Maintainer: Marcin (CTRL) Wieczorek <marcin@marcin.co>
-# Contributor: Tomas Storck <storcktomas@gmail.com
-# Contributor: Devin J. Pohly <djpohly+arch@gmail.com>
-
pkgname=java-commons-math
-_shortname=commons-math
-pkgver=3.6.1
+pkgver=4.0_beta1
+_pkmaior=4
pkgrel=1
pkgdesc='Apache Commons Mathematics Library'
arch=(any)
@@ -12,20 +8,21 @@ url='http://commons.apache.org/math/'
license=('APACHE')
depends=('java-runtime')
makedepends=('maven')
-source=("http://www-eu.apache.org/dist//commons/math/source/commons-math3-${pkgver}-src.tar.gz")
-md5sums=('9698be1b485d9ff35b7b23262cb42aee')
+# https://dlcdn.apache.org//commons/math/source/commons-math4-4.0-beta1-src.tar.gz
+source=("commons-math-${pkgver//_/-}-src.tar.gz::https://dlcdn.apache.org//commons/math/source/commons-math${_pkmaior}-${pkgver//_/-}-src.tar.gz")
+sha512sums=('668f552c444c7328bfb4e73bfba031e00d56212fc38a5d587ac9809ae63547b1caec7edb46a808dd62054601aaca696c3afa9fc4b6e5daa38d8c0db0f31a2ccd')
build() {
- cd "${srcdir}/commons-math3-${pkgver}-src"
+ cd "${srcdir}/commons-math-${pkgver//_/-}-src"
mvn install
}
package() {
- cd "${srcdir}/${_shortname}3-${pkgver}-src/"
+ cd "${srcdir}/commons-math-${pkgver//_/-}-src"
- install -Dm644 "target/${_shortname}3-${pkgver}.jar" "${pkgdir}/usr/share/java/${_shortname}/${_shortname}.jar"
- install -Dm644 "target/${_shortname}3-${pkgver}-tools.jar" "${pkgdir}/usr/share/java/${_shortname}/${_shortname}-tools.jar"
+ install -Dm644 "target/commons-math-${pkgver//_/-}.jar" "${pkgdir}/usr/share/java/${pkgname}/commons-math-${pkgver//_/-}.jar"
+ install -Dm644 "target/commons-math-${pkgver//_/-}-tools.jar" "${pkgdir}/usr/share/java/${pkgname}/commons-math-${pkgver//_/-}-tools.jar"
install -D -m644 "LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -D -m644 "NOTICE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/NOTICE"