summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6130ae8c0552..5b2dd600eb43 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ _build=b17
pkgver=${_major}u${_minor}
pkgrel=1
pkgdesc="Oracle Java Development Kit (v8) for ARMv7, ARMv6 and ARMv8 (64-bit)"
-arch=('armv6h' 'armv7h' 'armv8h')
+arch=('armv6h' 'armv7h' 'aarch64')
_carch=arm
url=http://www.oracle.com/technetwork/java/javase/downloads/index.html
license=('custom')
@@ -40,7 +40,7 @@ backup=("etc/java-$_jname/$_carch/jvm.cfg"
options=('!strip') # JDK debug-symbols
install=$_pkgname.install
-if [ $arch = 'armv8h' ]; then
+if [[ $CARCH == "aarch64" ]]; then
osarch=arm64
else
osarch=arm32