summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 20 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0cf6890c2236..a965bad69585 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,34 @@
-# $Id$
-# Maintainer: Sean V Kelley <seanvk@posteo.de>
-
+# Maintainer: RiverOnVenus <error@zhui.dev>
+# Contributor: Sean V Kelley <seanvk@posteo.de>
pkgname=jitterdebugger-git
-pkgver=r106.daeff0a
-pkgrel=3
+pkgver=0.3.r69.g7af8bc7
+pkgrel=1
pkgdesc="Real time response measurement tool"
arch=('i686' 'x86_64')
url="https://github.com/igaw/jitterdebugger"
license=('MIT')
-depends=('python3'
- 'hdf5>=1.8.17')
+depends=(
+ 'glibc'
+ 'python3'
+ 'python-pandas'
+ 'python-numpy'
+ 'python-matplotlib'
+ 'hdf5>=1.8.17'
+ )
makedepends=('git')
-provides=('jitterdebugger'
- 'jitterplot'
- 'jittersamples')
+provides=(
+ 'jitterdebugger'
+ 'jitterplot'
+ 'jittersamples'
+ )
+conflicts=('jitterdebugger')
options=('!emptydirs')
-changelog=
-# The git repo is detected by the 'git:' or 'git+' beginning. The branch
-# '$pkgname' is then checked out upon cloning, expediating versioning:
-#source=('git+https://github.com/igaw/jitterdebugger.git'
-source=("$pkgname"::'git://github.com/igaw/jitterdebugger.git')
-# Because the sources are not static, skip Git checksum:
+source=("$pkgname"::"git+${url}")
sha256sums=('SKIP')
pkgver() {
cd "$srcdir/$pkgname"
- # Since there are no tags currently on master, use number of revisions
- # since the beginning of history.
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long --tags --abbrev=7 | sed 's/-/.r/;s/-/./'
}
build() {
@@ -38,8 +39,6 @@ build() {
}
package() {
- cd "$srcdir/$pkgname"
- mkdir -p "$pkgdir/usr/share/licenses/$pkgname"
install -Dm644 "$srcdir/$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
install -Dm644 "$srcdir/$pkgname/man/jitterdebugger.1" "$pkgdir/usr/share/man/man1/jitterdebugger.1"
install -Dm644 "$srcdir/$pkgname/man/jitterplot.1" "$pkgdir/usr/share/man/man1/jitterplot.1"