summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 8 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b6905d9b911c..64d02700fef8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,19 @@
# Contributor: <qqqqqqqqq9 at web dot de>
# Contributor: yannsen <ynnsen at gmail dot com>
pkgname=jnc
-pkgver=0.19
+pkgver=0.20
pkgrel=1
-pkgdesc="A wrapper for the Juniper network connect client (ncsvc)"
-arch=('any')
+pkgdesc="A wrapper for the Juniper network connect client (ncsvc) and the Pulse Secure client (pulsesvc)"
+arch=('i686' 'x86_64')
url="http://www.scc.kit.edu/scc/net/juniper-vpn/linux/"
license=('GPL')
depends=('perl' 'openssl' 'net-tools')
-[[ $CARCH == "x86_64" ]] && depends=('perl' 'openssl' 'net-tools' 'lib32-nss-mdns' 'lib32-zlib')
-makedepends=()
-optdepends=('java: for Network Connect Java GUI, with x86_64 the Network Connect Java GUI will not work')
-source=(http://www.scc.kit.edu/scc/net/juniper-vpn/linux/$pkgname)
+depends_x86_64=('lib32-nss-mdns' 'lib32-zlib')
+optdepends=('java-runtime: for Network Connect Java GUI, with x86_64 the Network Connect Java GUI will not work')
+source=($pkgname-$pkgver::http://www.scc.kit.edu/scc/net/juniper-vpn/linux/$pkgname)
install=jnc.install
-sha256sums=('5eb2f187a32c009ca4e19042ee46e6a1b99a0ec0714b0b93f207b11440ff4fb7')
+sha256sums=('67854a7f7125dcce0e60bcd209738f23c718a27c551b7105a8d5ba717449aecc')
package() {
- install -d $pkgdir/usr/bin/
- install -m755 jnc $pkgdir/usr/bin/
+ install -Dm755 $pkgname-$pkgver "$pkgdir/usr/bin/$pkgname"
}
-