summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0f0825cea087
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Trizen <echo dHJpemVuQHByb3Rvbm1haWwuY29tCg== | base64 -d>
+
+_pkgname=perl-scripts
+pkgname=json2csv-git
+pkgver=22.07.r4.g34f39e2
+pkgrel=1
+pkgdesc="Convert a stream of newline separated JSON data to CSV format."
+arch=('any')
+url="https://github.com/trizen/${_pkgname}"
+license=('GPL3')
+makedepends=('git')
+
+provides=()
+conflicts=()
+
+depends=('perl>=5.10.0' 'perl-text-csv' 'perl-json')
+
+source=("git+https://github.com/trizen/${_pkgname}.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$_pkgname"
+ install -D -m 755 "Converters/json2csv.pl" "$pkgdir/usr/bin/json2csv.pl"
+}