summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 9 insertions, 28 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 30dab433fb10..3ea9d3cd7ee6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,44 +3,25 @@
_pkgname=junction
pkgname=junction-zhfix
-pkgdesc="Application/browser chooser"
-pkgver=1.6
-pkgrel=4
-#_tag=v$pkgver
-_commit=53ca01d7f3eca72a4a6bb0727ca6aa5eec3e63db
+pkgdesc="Application/browser chooser (zhfix fork)"
+pkgver=1.6.1
+pkgrel=1
+_tag=v$pkgver
+#_commit=0343689c5bf835b27ff18a2490e74e5e4d361e1d
arch=('x86_64' 'aarch64')
-url="https://github.com/sonnyp/Junction"
+url="https://github.com/detiam/Junction-zhfix"
license=('GPL3')
conflicts=("$_pkgname")
provides=("$_pkgname")
depends=('libadwaita' 'libportal-gtk4' 'gjs')
-makedepends=('git' 'meson' 'python-gobject' 'blueprint-compiler')
+makedepends=('git' 'meson' 'python-gobject' 'blueprint-compiler' 'xdg-utils')
checkdepends=('appstream-glib')
-source=("${_pkgname}-${pkgver}::git+$url.git#commit=$_commit")
+source=("${_pkgname}-${pkgver}::git+${url}.git#tag=${_tag}")
b2sums=('SKIP')
prepare() {
- cd "$_pkgname-$pkgver"
-
+ cd "${_pkgname}-${pkgver}"
git -c protocol.file.allow=always submodule update --init --recursive
-
- # fix Simplified Chinese translation
- pushd po
- sed -i 's/zh_Hans/zh_CN\nzh_SG/' LINGUAS
- ln -v zh_Hans.po zh_CN.po
- ln -v zh_Hans.po zh_SG.po
- popd
-
- # fix crash that happened when not in flatpak environment
- pushd src
- sed -i 's|XDG_DATA_DIRS.*e ||' bin.js
- popd
-
- # redirect output
- # if not, when use `xdg-open` there will have annoying log printed to terminal
- pushd data
- sed -i '/^Exec=/ s|$| 2>/dev/null|' re.sonny.Junction.desktop
- popd
}
build() {