summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 16 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2e552f7a6b31..c2d328fe5c29 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,33 @@
# Maintainer: Antonio Rojas <arojas@archlinux.org>
pkgname=jupyter-singular
-pkgver=0.9.2
+pkgver=0.9.9
pkgrel=1
pkgdesc="Jupyter kernel for Singular"
arch=(any)
url="https://github.com/sebasguts/jupyter_kernel_singular"
license=(GPL)
-depends=(python-pysingular jupyter-notebook python-ipywidgets)
+depends=(ipython
+ jupyter-notebook
+ python
+ python-ipykernel
+ python-ipywidgets
+ python-pexpect
+ python-pysingular)
+makedepends=(python-build
+ python-installer
+ python-setuptools
+ python-wheel)
source=(https://pypi.io/packages/source/j/jupyter_kernel_singular/jupyter_kernel_singular-$pkgver.tar.gz)
-md5sums=('915e2e89b759297a8aebcfe8ca400cbb')
+md5sums=('40464609dec908950af7058ded8d93e2')
build() {
cd jupyter_kernel_singular-$pkgver
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd jupyter_kernel_singular-$pkgver
- python setup.py install --skip-build --root="$pkgdir" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ mv "$pkgdir"{/usr,}/etc
}