summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 500fe1480b76..7d3cd1072edc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,16 @@
# Thanks to kate-latex-plugin.git which was my starting point for this PKGBUILD
pkgname="kate-indexview-plugin"
_pkgname="KatePlugin-IndexView"
-pkgver="0.9.1"
+pkgver="0.9.2"
pkgrel="1"
-pkgdesc="A fork from Kate's SymbolViewer plugin with a couple of improvements"
+pkgdesc="A fork from Kate's SymbolViewer plugin with a couple of modifications"
arch=("i686" "x86_64")
url="https://github.com/loh-tar/$_pkgname"
-license=("LGPL")
-depends=("kate")
+license=("LGPL-2.0-or-later")
+depends=("kate>=24.02.0")
makedepends=("cmake" "extra-cmake-modules")
source=("$pkgname-$pkgver.tar.gz::https://github.com/loh-tar/$_pkgname/archive/v$pkgver.tar.gz")
-md5sums=('80dc4fc4638d769add8c17ca52914255')
+md5sums=('d323095ef93d087602ac58581d245a9e')
build()
{
@@ -30,5 +30,6 @@ build()
package()
{
cd "$srcdir/build"
- make DESTDIR="$pkgdir" install
+ # make DESTDIR="$pkgdir" install
+ install -Dm755 index-view/kateindexviewplugin.so "$pkgdir/usr/lib/qt6/plugins/kf6/ktexteditor/index-view/kateindexviewplugin.so"
}