summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a7099ae029e1..f602e19766b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Gustavo Castro < gustawho [ at ] gmail [ dot ] com >
pkgname=keepassk-git
-pkgver=r2.f88dfc0
+pkgver=r4.0d0dc87
pkgrel=1
pkgdesc="A Kirigami password manager for KDBX password databases"
-arch=(x86_64 aarch64)
+arch=(x86_64 i686 arm armv6h armv7h aarch64)
url="https://invent.kde.org/tfella/keepassk"
license=(GPL3)
depends=('ki18n' 'kirigami2' 'kcoreaddons')
-makedepends=('git' 'extra-cmake-modules' 'corrosion-git' 'qt5-svg')
+makedepends=('git' 'extra-cmake-modules' 'corrosion-git' 'qt5-svg' 'qt5-tools')
provides=('keepassk')
conflicts=('keepassk')
source=("git+${url}.git")
@@ -23,10 +23,10 @@ pkgver() {
}
build() {
- cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -B build -S "${pkgname%-git}"
- cmake --build build --config Release
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=RelWithDebInfo -B build -S "${pkgname%-git}"
+ cmake --build build --config RelWithDebInfo
}
package() {
- DESTDIR="${pkgdir}" cmake --install build --config Release
-}
+ DESTDIR="${pkgdir}" cmake --install build --config RelWithDebInfo
+} \ No newline at end of file