summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d031e5b32b04..e987884f8429 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Schopf <schopf.dan at gmail dot com>
pkgname=kim-api
-pkgver=2.1.3
-pkgrel=3
+pkgver=2.2.1
+pkgrel=1
pkgdesc="Online framework for reliable, reproducible and portable molecular simulations"
arch=("i686" "x86_64")
url="https://openkim.org"
@@ -10,15 +10,10 @@ depends=(xxd)
optdepends=('doxygen: build OpenKIM documentation')
makedepends=(cmake gcc-fortran)
install=$pkgname.install
-source=(https://s3.openkim.org/kim-api/kim-api-${pkgver}.txz
- Fix-Doxygen-command-error.patch)
-sha512sums=('efbc0214234b43a65ed40d23d8faa5264ac1dbd056e9e340548ea7ee5dc530f9cfb2d85a1d9d47fba9dfc7aa660a8ec20374daf4aa8ee605e7c097ae2a12512d'
- '0063cb18884a19d15261e910cc9877ff319f9c1b428023d736e34b5271f254a7eaca9b90033f80af560199e1fe363523da6afb4ee35a05af76b2760039a94cbd')
+source=(https://s3.openkim.org/kim-api/kim-api-${pkgver}.txz)
+sha512sums=('b2625dc41474849f281f266a1fa8a2b1738d2433031d2181bde36ac5ec050fcdec3925cb588b287a46c80c01c730be04352ca88a9ba71fc3b37c2da1c84ae650')
prepare() {
- cd "$pkgname-$pkgver"
- patch -p1 -i ../Fix-Doxygen-command-error.patch
- cd ..
mkdir -p build
}
@@ -38,4 +33,8 @@ build() {
package() {
cd build
make DESTDIR="$pkgdir" install
+ cd "$pkgdir"/usr/share/emacs/site-lisp
+ mv kim-api/*.el .
+ rmdir kim-api
+ cd ../../..
}