summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b461ada9bb3e..3402b5a7b1e0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,8 @@
pkgname=kitch
pkgver=1.14.0
-pkgrel=2
+pkgrel=3
+epoch=1
pkgdesc="The best way to play itch.io games."
arch=('i686' 'x86_64')
@@ -18,12 +19,11 @@ install="kitch.install"
[ "$CARCH" = "i686" ] && _ITCH_ARCH=386;
[ "$CARCH" = "x86_64" ] && _ITCH_ARCH=amd64;
-source=("https://github.com/itchio/itch/archive/v25.4.0.tar.gz")
-sha256sums=('e86c70044c7d02754c6e52fb428d1278678d729c77b8359b5d82198595da1351')
-
-prepare() {
- curl --fail --location --output kitch-setup "https://broth.itch.ovh/kitch-setup/linux-${_ITCH_ARCH}/${pkgver}/unpacked/default"
-}
+source=(
+ "https://github.com/itchio/itch/archive/v25.4.0.tar.gz"
+ "kitch-setup::https://broth.itch.ovh/kitch-setup/linux-${_ITCH_ARCH}/${pkgver}/unpacked/default")
+sha256sums=('e86c70044c7d02754c6e52fb428d1278678d729c77b8359b5d82198595da1351'
+ '5e3c70c2c3594e44b7df204acb13684dae69575963c33797191c345e6076202d')
package() {
install -Dm755 kitch-setup "${pkgdir}/usr/bin/kitch-setup"