summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7ccc0121081d..b1c334d5e9bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,20 +3,25 @@
# Contributor: Andrea Scarpino <andrea@archlinux.org>
pkgname=kjs-git
-pkgver=_r390.gabe9f2d
+pkgver=5.116.0_r421.gdb9aedd
pkgrel=1
pkgdesc='Support for JS scripting in applications'
arch=($CARCH)
url='https://community.kde.org/Frameworks'
license=(LGPL)
depends=(qt5-base pcre)
-makedepends=(git extra-cmake-modules-git kdoctools5-git)
+makedepends=(git extra-cmake-modules-git kdoctools5)
conflicts=(${pkgname%-git})
provides=(${pkgname%-git})
groups=(kf5-aids-git)
source=("git+https://github.com/KDE/${pkgname%-git}.git")
sha256sums=('SKIP')
+prepare() {
+ cd ${pkgname%-git}
+ git checkout kf5
+}
+
pkgver() {
cd ${pkgname%-git}
_ver="$(grep -m1 'set(KF5\?_VERSION' CMakeLists.txt | cut -d '"' -f2 | tr - .)"