summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 15 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 885e17ca16c6..a7042aa06a16 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
pkgname=ktorrent-git
-pkgver=24.01.75.r3167.64e383cd
+pkgver=24.04.70.r3267.177a8d69
pkgrel=1
pkgdesc="A powerful BitTorrent client. (GIT version)"
arch=('x86_64')
@@ -34,9 +34,10 @@ depends=(
'hicolor-icon-theme'
)
makedepends=(
+ 'git'
'extra-cmake-modules'
+ 'qt6-tools'
'kdoctools'
- 'git'
'python'
'boost'
'taglib'
@@ -68,8 +69,14 @@ provides=(
'libktcore.so'
)
conflicts=('ktorrent')
-source=('git+https://invent.kde.org/network/ktorrent.git')
-sha256sums=('SKIP')
+source=(
+ 'git+https://invent.kde.org/network/ktorrent.git'
+ 'https://invent.kde.org/network/ktorrent/-/merge_requests/57.diff'
+)
+sha256sums=(
+ 'SKIP'
+ 'SKIP'
+)
options=('debug')
pkgver() {
@@ -78,6 +85,10 @@ pkgver() {
echo "${_ver}.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
}
+prepare() {
+ patch -d ktorrent -p1 -i "${srcdir}/57.diff"
+}
+
build() {
cmake -S ktorrent -B build \
-DCMAKE_BUILD_TYPE=None \