summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 4 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fcacb625e040..65d852fbb658 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_bin=kubectl-unused_volumes
pkgname=${_bin/_/-}
pkgver=0.1.2
-pkgrel=2
+pkgrel=3
pkgdesc='Clean up Kuberntes yaml and json output to make it readable'
arch=('x86_64' 'i686')
url='https://github.com/dirathea/kubectl-unused-volumes'
@@ -13,11 +13,6 @@ groups=('kubectl-plugins')
source=("${url}/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz")
sha256sums=('4743b53246ed24593a522c7d45710ff7e2808ee7eed87b69e9b5ea406844fbdb')
-prepare() {
- cd "${pkgname}-${pkgver}"
- go mod vendor
-}
-
build() {
cd "${pkgname}-${pkgver}"
export CGO_ENABLED=1
@@ -25,8 +20,8 @@ build() {
export CGO_CFLAGS="$CFLAGS"
export CGO_CPPFLAGS="$CPPFLAGS"
export CGO_CXXFLAGS="$CXXFLAGS"
- export GOFLAGS='-buildmode=pie -ldflags=-linkmode=external -modcacherw -mod=readonly -trimpath'
- go build -o "$_bin" ./cmd/plugin
+ export GOFLAGS='-buildmode=pie -modcacherw -trimpath'
+ go build -ldflags "-linkmode=external" ./cmd/plugin
}
check() {
@@ -36,6 +31,6 @@ check() {
package() {
cd "${pkgname}-${pkgver}"
- install -Dm755 "$_bin" -t "${pkgdir}/usr/bin"
+ install -Dm755 plugin -t "${pkgdir}/usr/bin/$_bin"
install -Dm644 doc/USAGE.md -t "${pkgdir}/usr/share/doc/${pkgname}"
}