summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index be0c7206f16b..8797ef9a988f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=lenmus
pkgver=6.0.1
-pkgrel=1
+pkgrel=2
pkgdesc="A free program for learning music"
arch=('i686' 'x86_64')
url="http://www.lenmus.org/"
@@ -12,12 +12,15 @@ depends=('portmidi' 'wxwidgets-gtk3' 'sqlite3' 'fluidsynth' 'soundfont-fluid')
optdepends=('timidity++: for sound without external midi player')
makedepends=('unittestpp' 'cmake' 'lsb-release')
-source=("https://github.com/lenmus/lenmus/archive/Release_${pkgver}.tar.gz")
-sha256sums=('1fa5b8edc468c800598845aa809b4a4e93058ed13af40bfacd037c44d1c4bc1d')
+source=("https://github.com/lenmus/lenmus/archive/Release_${pkgver}.tar.gz"
+ "0002-PortTime-included.patch")
+sha256sums=('1fa5b8edc468c800598845aa809b4a4e93058ed13af40bfacd037c44d1c4bc1d'
+ '7e23b83488bce81489f063dd59a625ed3fdd5be545e10cecd256794be80a2fcf')
prepare() {
cd "$srcdir"/${pkgname}-Release_${pkgver}
rm cmake-modules/FindSQLite3.cmake
+ patch -p0 -i "$srcdir/0002-PortTime-included.patch"
}
build() {