summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 24 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8fd0a6f6f8fc..56a3d3c95b6f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,43 @@
-# Maintainer : speps <speps at aur dot archlinux dot org>
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+# Contributor: speps <speps at aur dot archlinux dot org>
# Contributor: Marco Süß <m_a_r_c_o.suess at gmx.de>
-_name=lash
-pkgname=lib32-$_name
+_pkgname=lash
+pkgname=lib32-$_pkgname
pkgver=0.6.0~rc2
_relver=0.6.0.594
-pkgrel=2
-pkgdesc="A session management system for JACK and ALSA. Multilib."
+pkgrel=3
+pkgdesc="A session management system for JACK and ALSA (32-bit)"
arch=('x86_64')
-options=('!libtool')
url="http://lash.nongnu.org"
license=('GPL')
-depends=('lash' 'lib32-dbus-core' 'lib32-util-linux' 'lib32-jack' 'jackdbus')
-makedepends=('gcc-multilib' 'libtool-multilib')
-source=("http://download.savannah.gnu.org/releases/lash/$_name-$pkgver.tar.bz2")
+depends=('lash' 'lib32-dbus' 'jack' 'lib32-util-linux')
+makedepends=('gcc-multilib' 'libtool-multilib' 'lib32-python2')
+optdepends=('lib32-python2: Python bindings')
+source=("http://download.savannah.gnu.org/releases/lash/${_pkgname}-${pkgver}.tar.bz2")
md5sums=('af1dc4f4ceb284b1b0845de4f4c2fe47')
build() {
- cd "$srcdir/$_name-$_relver"
+ cd "${srcdir}/${_pkgname}-${_relver}"
- export CC='gcc -m32'
- export CXX='g++ -m32'
+ # We can't put the python includes in *FLAGS since that way they would be
+ # overwritten with the 64-bit ones by the build system of lash
+ export CC='gcc -m32 -I/usr/lib32/python2.7/include/python2.7'
+ export CXX='g++ -m32 -I/usr/lib32/python2.7/include/python2.7'
export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
+ export PYTHON='/usr/bin/python2-32'
./configure --prefix=/usr \
--libdir=/usr/lib32 \
- --enable-static=no \
- --without-python
- cd liblash && make
+ --enable-static=no
+ make -C liblash
+ make -C pylash
}
package() {
- cd "$srcdir/$_name-$_relver/liblash"
- make DESTDIR="$pkgdir/" install
+ cd "${srcdir}/${_pkgname}-${_relver}"
+
+ make install-pkgconfigDATA DESTDIR="${pkgdir}"
+ make -C liblash install DESTDIR="${pkgdir}"
+ make -C pylash install DESTDIR="${pkgdir}"
}