summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 6 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e81e1039f7ce..8a0f0bfeb705 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,37 +8,25 @@ pkgrel=10
arch=('i686' 'x86_64')
url="http://libexplain.sourceforge.net/"
license=('LGPLv2')
-makedepends=('libcap' 'lsof' 'libtool' 'groff' 'bison' 'gcc')
+makedepends=('libcap' 'lsof' 'libtool' 'groff' 'bison' 'gcc' 'quilt')
source=("git+https://salsa.debian.org/debian/libexplain#tag=debian/${pkgver}-${pkgrel}")
+options=(libtool staticlibs)
sha256sums=('SKIP')
prepare() {
cd "$srcdir/$pkgname"
-
- patch -Np1 -i debian/patches/01_autofoo.patch
- patch -Np1 -i debian/patches/02_alpha-fcntl-h.patch
- patch -Np1 -i debian/patches/03_fsflags-4.5.patch
- patch -Np1 -i debian/patches/04_test-t0274a.patch
- patch -Np1 -i debian/patches/05_largefile.patch
- patch -Np1 -i debian/patches/06_sysctl.patch
- patch -Np1 -i debian/patches/07_ustat.patch
- patch -Np1 -i debian/patches/08_hppa.patch
- patch -Np1 -i debian/patches/fix-tests-sed.patch
- patch -Np1 -i debian/patches/gcc-10.patch
- patch -Np1 -i debian/patches/nettstamp-needs-types.patch
- patch -Np1 -i debian/patches/sanitize-bison.patch
- patch -Np1 -i debian/patches/typos.patch
+ QUILT_PATCHES=debian/patches quilt push -a
}
build() {
cd "$srcdir/$pkgname"
- ./configure --prefix=/usr
- make
+ CPPFLAGS='-fPIC' ./configure --prefix=/usr
+ make -j$(nproc)
}
package() {
cd "$srcdir/$pkgname"
- make DESTDIR="$pkgdir/" install
+ make install DESTDIR="$pkgdir/"
}
# vim:set ts=2 sw=2 et: