summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 18 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2466f0739b61..8ee2156be561 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: Alyxia Sother <nylkvn@evfrhc.arg(rot13)>
pkgname=libhelium
-pkgver=1.8.9
-pkgrel=2
+pkgver="1.8.11.1"
+_pkgver="1.8.11-1"
+pkgrel=1
pkgdesc="The application framework for tauOS apps."
arch=('x86_64' 'aarch64')
depends=('gtk4' 'glib2' 'libgee')
@@ -17,24 +18,34 @@ makedepends=(
url="https://github.com/tau-OS/libhelium"
license=('LGPL3')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/tau-OS/libhelium/archive/refs/tags/$pkgver.tar.gz")
-sha256sums=('8ec5fa64f64b77524993b959d6309798f35fa8326bbad5ec28a59f15b562e532')
+source=("$pkgname-$_pkgver.tar.gz::https://github.com/tau-OS/libhelium/archive/refs/tags/$_pkgver.tar.gz"
+ "$pkgname.patch")
+sha256sums=('c11de0b77af5adca540b6592a58887f6d071772ef48485dbef9f49e4c0a42f46'
+ '2588353199c954d25a630ef1953f5f1532eeb6aa550be1267b4fe3ec68fcfef1')
prepare() {
- cd "$srcdir/libhelium-$pkgver"
+ cd "$srcdir/libhelium-$_pkgver"
meson subprojects download
+
+ # Removes the automatic schema compilation, we're doing this ourselves
+ patch --strip=1 --input="$srcdir/$pkgname.patch"
}
build() {
- cd "$srcdir/libhelium-$pkgver"
+ cd "$srcdir/libhelium-$_pkgver"
arch-meson . builddir -Dvaladoc=false -Ddemo=false
meson compile -C builddir
}
package() {
- cd "$srcdir/libhelium-$pkgver"
+ cd "$srcdir/libhelium-$_pkgver"
meson install -C builddir --destdir "$pkgdir"
+
+ # Manually add the schema into the right data dir.
+ # We don't have to call glib-compile-schemas as glib2 contains a hook:
+ # <https://gitlab.archlinux.org/archlinux/packaging/packages/glib2/-/blob/main/glib-compile-schemas.hook?ref_type=heads>
+ install -Dm644 data/com.fyralabs.desktop.appearance.gschema.xml "$pkgdir/usr/share/glib-2.0/schemas/com.fyralabs.desktop.appearance.gschema.xml"
}