summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 64135dd7086d..4b06b316323a 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,20 @@
# Inmarsat-C library
# Maintainer: cropinghigh <joinmark60@gmail.com>
pkgname=libinmarsatc-git
-pkgver=1.0
+pkgver=r13.31c6f5e
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc="Inmarsat-C Open-source library based on Scytale-c"
license=('GPL')
provides=("libinmarsatc")
-source=("git://github.com/cropinghigh/inmarsatc")
+source=("git+https://github.com/cropinghigh/inmarsatc")
md5sums=('SKIP')
+pkgver() {
+ cd "$srcdir/inmarsatc"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
build() {
cd $srcdir/inmarsatc
mkdir build