summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 71480153bef1..2122b1879e4d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,22 @@
pkgname=libomemo
pkgver=0.6.2
-pkgrel=1
+pkgrel=2
pkgdesc="Implements OMEMO in C"
arch=('i686' 'x86_64')
url='https://github.com/gkdr/libomemo'
license=('MIT')
depends=('mxml' 'libgcrypt' 'glib2' 'sqlite')
makedepends=()
-source=("https://github.com/gkdr/libomemo/archive/v${pkgver}.tar.gz")
-md5sums=('57a838ae647a94e409c01b9ee9869945')
+source=(
+ "https://github.com/gkdr/libomemo/archive/v${pkgver}.tar.gz"
+ "0003-12-byte-IVs.patch"
+)
+sha265sums=('57a838ae647a94e409c01b9ee9869945')
build() {
cd "${srcdir}/libomemo-${pkgver}"
+ patch -p1 --input="${srcdir}/0003-12-byte-IVs.patch"
make
}
@@ -24,3 +28,5 @@ package() {
mkdir -p "${pkgdir}/usr/include"
install src/*.h "${pkgdir}/usr/include"
}
+md5sums=('57a838ae647a94e409c01b9ee9869945'
+ 'ab4a4319f589b3b28578c34b4d3abae9')