summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD29
1 files changed, 7 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 57a154436ea7..b7328ef60f83 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-#Maintainer: Kimiblock <pn3535@icloud.com>
+#Maintainer: Kimiblock
pkgname=librewolf-extension-violentmonkey-bin
url="https://github.com/violentmonkey/violentmonkey"
@@ -9,27 +9,12 @@ pkgdesc="Violentmonkey provides userscripts support for browsers. It works on br
arch=('any')
license=('MIT')
-function pkgver(){
- _rawVersion=$(curl -s https://api.github.com/repos/violentmonkey/violentmonkey/releases/latest | jq .tag_name)
- echo ${_rawVersion} | cut -c 3-$(expr ${#_rawVersion} - 1)
-}
+#function pkgver(){
+# _rawVersion=$(curl -s https://api.github.com/repos/violentmonkey/violentmonkey/releases/latest | #jq .tag_name)
+# echo ${_rawVersion} | cut -c 3-$(expr ${#_rawVersion} - 1)
+#}
function package(){
- mkdir -p "${pkgdir}"/usr/lib/librewolf/browser/extensions
- _info "Downloading Violentmonkey ${pkgver}"
- curl "https://github.com/violentmonkey/violentmonkey/releases/download/v${pkgver}/violentmonkey-${pkgver}.xpi" -o "${pkgdir}/usr/lib/librewolf/browser/extensions/{aecec67f-0d10-4fa7-b7c7-609a2db280cf}.xpi" -L
- chmod 0644 "${pkgdir}"/usr/lib/librewolf/browser/extensions/*
-}
-
-
-function _info() {
- if [ -f /usr/bin/pamac ]; then
- echo " ==> [Info]: $@"
- else
- all_off="$(tput sgr0)"
- bold="${all_off}$(tput bold)"
- blue="${bold}$(tput setaf 4)"
- yellow="${bold}$(tput setaf 3)"
- printf "${blue}==>${yellow} [Info]:${bold} $1${all_off}\n"
- fi
+ curl "https://github.com/violentmonkey/violentmonkey/releases/download/v${pkgver}/violentmonkey-${pkgver}.xpi" -o "${srcdir}/ext.xpi" -L
+ install -Dm644 ext.xpi "${pkgdir}/usr/lib/librewolf/browser/extensions/{aecec67f-0d10-4fa7-b7c7-609a2db280cf}.xpi"
}