summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 22 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9acb10573de0..408394041a7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,22 +8,27 @@
# If you want to help keep it up to date, please open a Pull Request there.
pkgname=libselinux
-pkgver=3.0
-pkgrel=1
+pkgver=3.6
+pkgrel=4
pkgdesc="SELinux library and simple utilities"
-arch=('i686' 'x86_64' 'armv6h')
-url='http://userspace.selinuxproject.org'
+arch=('i686' 'x86_64' 'armv6h' 'aarch64')
+url='https://github.com/SELinuxProject/selinux'
license=('custom')
groups=('selinux')
-makedepends=('python' 'ruby' 'xz' 'swig')
-depends=('libsepol>=3.0' 'pcre')
+makedepends=('pkgconf' 'python' 'python-pip' 'python-setuptools' 'ruby' 'xz' 'swig')
+depends=('libsepol>=3.6' 'pcre2')
optdepends=('python: python bindings'
'ruby: ruby bindings')
conflicts=("selinux-usr-${pkgname}")
provides=("selinux-usr-${pkgname}=${pkgver}-${pkgrel}")
-source=("https://github.com/SELinuxProject/selinux/releases/download/20191204/${pkgname}-${pkgver}.tar.gz"
+validpgpkeys=(
+ '63191CE94183098689CAB8DB7EF137EC935B0EAF' # Jason Zaman <perfinion@gentoo.org>
+ 'B8682847764DF60DF52D992CBC3905F235179CF1' # Petr Lautrbach <plautrba@redhat.com>
+)
+source=("https://github.com/SELinuxProject/selinux/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz"{,.asc}
"libselinux.tmpfiles.d")
-sha256sums=('2ea2b30f671dae9d6b1391cbe8fb2ce5d36a3ee4fb1cd3c32f0d933c31b82433'
+sha256sums=('ba4e0ef34b270e7672a5e5f1b523fe2beab3a40bb33d9389f4ad3a8728f21b52'
+ 'SKIP'
'afe23890fb2e12e6756e5d81bad3c3da33f38a95d072731c0422fbeb0b1fa1fc')
build() {
@@ -32,6 +37,11 @@ build() {
# Do not build deprecated rpm_execcon() interface. It is useless on Arch Linux anyway.
export DISABLE_RPM=y
+ # Use pcre2 explicitely even though it is the default since
+ # https://github.com/SELinuxProject/selinux/commit/e0da140d82c0ebebf1060ce87d0f11276c7fc59a
+ export USE_PCRE2=y
+
+ export CFLAGS="${CFLAGS} -fno-semantic-interposition"
make swigify
make all
make PYTHON=/usr/bin/python3 pywrap
@@ -39,6 +49,10 @@ build() {
}
package() {
+ provides+=(
+ libselinux.so
+ )
+
cd "${pkgname}-${pkgver}"
export DISABLE_RPM=y
@@ -47,7 +61,6 @@ package() {
make DESTDIR="${pkgdir}" PYTHON=/usr/bin/python3 SBINDIR=/usr/bin SHLIBDIR=/usr/lib install-pywrap
make DESTDIR="${pkgdir}" RUBY=/usr/bin/ruby SBINDIR=/usr/bin SHLIBDIR=/usr/lib install-rubywrap
/usr/bin/python3 -m compileall "${pkgdir}/$(/usr/bin/python3 -c 'from distutils.sysconfig import *; print(get_python_lib(plat_specific=1))')"
- /usr/bin/python3 -O -m compileall "${pkgdir}/$(/usr/bin/python3 -c 'from distutils.sysconfig import *; print(get_python_lib(plat_specific=1))')"
install -Dm 0644 "${srcdir}"/libselinux.tmpfiles.d "${pkgdir}"/usr/lib/tmpfiles.d/libselinux.conf