summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 11 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c942e28ed23f..a6ac839a08a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,10 +4,9 @@
# Contributor: Eric BĂ©langer <eric@archlinux.org>
# Contributor: Joost Bremmer <toost dot b at gmail dot com>
-pkgname=libtiff3
+pkgname=(libtiff3 libtiff4)
pkgver=3.9.7
-pkgrel=2
-pkgdesc="Library for manipulation of TIFF images (legacy version)"
+pkgrel=4
arch=('i686' 'x86_64')
url="http://www.remotesensing.org/libtiff/"
license=('custom')
@@ -16,7 +15,6 @@ makedepends=('freeglut')
optdepends=('freeglut: for using tiffgt')
source=("http://download.osgeo.org/libtiff/tiff-$pkgver.tar.gz")
sha256sums=('f5d64dd4ce61c55f5e9f6dc3920fbe5a41e02c2e607da7117a35eb5c320cef6a')
-provides=('libtiff3' 'libtiff4')
build() {
cd tiff-$pkgver
@@ -29,7 +27,9 @@ check() {
make check
}
-package() {
+package_libtiff3() {
+ pkgdesc="Library for manipulation of TIFF images (legacy version, provides libtiff.so.3)"
+
cd tiff-$pkgver
make DESTDIR="$pkgdir" install
install -D -m644 COPYRIGHT "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
@@ -40,8 +40,14 @@ package() {
rm -rf "$pkgdir"/usr/include
rm -rf "$pkgdir"/usr/share/man
rm -rf "$pkgdir"/usr/share/doc
+}
+
+package_libtiff4() {
+ pkgdesc="Library for manipulation of TIFF images (legacy version, provides libtiff.so.4)"
+ depends+=('libtiff3')
# see http://www.asmail.be/msg0055009514.html
+ install -d "$pkgdir"/usr/lib
ln -sf libtiff.so.$pkgver "$pkgdir"/usr/lib/libtiff.so.4
ln -sf libtiffxx.so.$pkgver "$pkgdir"/usr/lib/libtiffxx.so.4
}