summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 2 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bfaf522b2f4e..af28cacf10c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,13 @@
pkgname=lighthouse-ethereum
pkgver=5.1.3
_pkgname=lighthouse
-pkgrel=1
+pkgrel=2
pkgdesc='Ethereum 2.0 client'
arch=('x86_64' 'aarch64')
url='https://lighthouse.sigmaprime.io/'
license=('Apache License 2.0')
depends=('openssl')
makedepends=('cargo' 'cmake' 'clang' 'protobuf')
-provides=('lighthouse')
-conflicts=('lighthouse')
-replaces=('lighthouse')
source=("git+https://github.com/sigp/lighthouse.git#tag=v$pkgver")
sha256sums=('SKIP')
@@ -22,6 +19,6 @@ build() {
package() {
cd ${_pkgname}
- install -D -m755 "$srcdir/$_pkgname/target/release/lighthouse" "$pkgdir/usr/bin/lighthouse"
+ install -D -m755 "$srcdir/$_pkgname/target/release/lighthouse" "$pkgdir/usr/bin/lighthouse-ethereum"
install -D -m644 "$srcdir/$_pkgname/LICENSE" "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
}