summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD183
1 files changed, 96 insertions, 87 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a991b689acb8..a0eba7e47498 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,7 +21,7 @@ _clangbuild=
# Optionally select a sub architecture by number or leave blank which will
# require user interaction during the build. Note that the generic (default)
-# option is 36.
+# option is 39.
_subarch=
# 1. AMD Opteron/Athlon64/Hammer/K8 (MK8)
@@ -37,105 +37,103 @@ _subarch=
# 11. AMD Zen (MZEN) (NEW)
# 12. AMD Zen 2 (MZEN2) (NEW)
# 13. AMD Zen 3 (MZEN3) (NEW)
-# 14. Intel P4 / older Netburst based Xeon (MPSC)
-# 15. Intel Core 2 (MCORE2)
-# 16. Intel Atom (MATOM)
-# 17. Intel Nehalem (MNEHALEM) (NEW)
-# 18. Intel Westmere (MWESTMERE) (NEW)
-# 19. Intel Silvermont (MSILVERMONT) (NEW)
-# 20. Intel Goldmont (MGOLDMONT) (NEW)
-# 21. Intel Goldmont Plus (MGOLDMONTPLUS) (NEW)
-# 22. Intel Sandy Bridge (MSANDYBRIDGE) (NEW)
-# 23. Intel Ivy Bridge (MIVYBRIDGE) (NEW)
-# 24. Intel Haswell (MHASWELL) (NEW)
-# 25. Intel Broadwell (MBROADWELL) (NEW)
-# 26. Intel Skylake (MSKYLAKE) (NEW)
-# 27. Intel Skylake X (MSKYLAKEX) (NEW)
-# 28. Intel Cannon Lake (MCANNONLAKE) (NEW)
-# 29. Intel Ice Lake (MICELAKE) (NEW)
-# 30. Intel Cascade Lake (MCASCADELAKE) (NEW)
-# 31. Intel Cooper Lake (MCOOPERLAKE) (NEW)
-# 32. Intel Tiger Lake (MTIGERLAKE) (NEW)
-# 33. Intel Sapphire Rapids (MSAPPHIRERAPIDS) (NEW)
-# 34. Intel Rocket Lake (MROCKETLAKE) (NEW)
-# 35. Intel Alder Lake (MALDERLAKE) (NEW)
-# 36. Generic-x86-64 (GENERIC_CPU)
-# 37. Generic-x86-64-v2 (GENERIC_CPU2) (NEW)
-# 38. Generic-x86-64-v3 (GENERIC_CPU3) (NEW)
-# 39. Generic-x86-64-v4 (GENERIC_CPU4) (NEW)
-# 40. Intel-Native optimizations autodetected by GCC (MNATIVE_INTEL) (NEW)
-# 41. AMD-Native optimizations autodetected by GCC (MNATIVE_AMD) (NEW)
+# 14. AMD Zen 4 (MZEN4) (NEW)
+# 15. Intel P4 / older Netburst based Xeon (MPSC)
+# 16. Intel Core 2 (MCORE2)
+# 17. Intel Atom (MATOM)
+# 18. Intel Nehalem (MNEHALEM) (NEW)
+# 19. Intel Westmere (MWESTMERE) (NEW)
+# 20. Intel Silvermont (MSILVERMONT) (NEW)
+# 21. Intel Goldmont (MGOLDMONT) (NEW)
+# 22. Intel Goldmont Plus (MGOLDMONTPLUS) (NEW)
+# 23. Intel Sandy Bridge (MSANDYBRIDGE) (NEW)
+# 24. Intel Ivy Bridge (MIVYBRIDGE) (NEW)
+# 25. Intel Haswell (MHASWELL) (NEW)
+# 26. Intel Broadwell (MBROADWELL) (NEW)
+# 27. Intel Skylake (MSKYLAKE) (NEW)
+# 28. Intel Skylake X (MSKYLAKEX) (NEW)
+# 29. Intel Cannon Lake (MCANNONLAKE) (NEW)
+# 30. Intel Ice Lake (MICELAKE) (NEW)
+# 31. Intel Cascade Lake (MCASCADELAKE) (NEW)
+# 32. Intel Cooper Lake (MCOOPERLAKE) (NEW)
+# 33. Intel Tiger Lake (MTIGERLAKE) (NEW)
+# 34. Intel Sapphire Rapids (MSAPPHIRERAPIDS) (NEW)
+# 35. Intel Rocket Lake (MROCKETLAKE) (NEW)
+# 36. Intel Alder Lake (MALDERLAKE) (NEW)
+# 37. Intel Raptor Lake (MRAPTORLAKE) (NEW)
+# 38. Intel Meteor Lake (MMETEORLAKE) (NEW)
+# 39. Generic-x86-64 (GENERIC_CPU)
+# 40. Generic-x86-64-v2 (GENERIC_CPU2) (NEW)
+# 41. Generic-x86-64-v3 (GENERIC_CPU3) (NEW)
+# 42. Generic-x86-64-v4 (GENERIC_CPU4) (NEW)
+# 43. Intel-Native optimizations autodetected by the compiler (MNATIVE_INTEL) (NEW)
+# 44. AMD-Native optimizations autodetected by the compiler (MNATIVE_AMD) (NEW)
### IMPORTANT: Do no edit below this line unless you know what you're doing
pkgbase=linux-ck
-pkgver=5.18.6
+pkgver=6.8.9
+_upstream=arch1
pkgrel=1
arch=(x86_64)
url="https://wiki.archlinux.org/index.php/Linux-ck"
-license=(GPL2)
+license=(GPL-2.0-only)
makedepends=(
- bc libelf cpio perl tar xz
+ bc
+ cpio
+ gettext
+ libelf
+ pahole
+ perl
+ python
+ tar
+ xz
)
[[ -n "$_clangbuild" ]] && makedepends+=(clang llvm lld python)
-options=('!strip')
+options=(
+ !debug
+ !strip
+)
# https://ck-hack.blogspot.com/2021/08/514-and-future-of-muqss-and-ck-once.html
# acknowledgment to xanmod for initially keeping the hrtimer patches up to date
-_ckhrtimer=linux-5.17.y
-_commit=5d3a0424bdbfdf2fc4cca389bf0f1ee4876e782d
+_ckhrtimer=linux-6.8.y
+_commit=ae3cbb29c43ca1baa6781f547d17b8ee5663e9d7
-_gcc_more_v=20220315
+_gcc_more_v=20240221.2
source=(
- "https://www.kernel.org/pub/linux/kernel/v5.x/linux-$pkgver.tar".{xz,sign}
- config # the main kernel config file
+ "https://www.kernel.org/pub/linux/kernel/v6.x/linux-$pkgver.tar".{xz,sign}
+ config # the main kernel config file
+ "https://github.com/archlinux/linux/releases/download/v$pkgver-$_upstream/linux-v$pkgver-$_upstream.patch.zst"
"more-uarches-$_gcc_more_v.tar.gz::https://github.com/graysky2/kernel_compiler_patch/archive/$_gcc_more_v.tar.gz"
"ck-hrtimer-$_commit.tar.gz::https://github.com/graysky2/linux-patches/archive/$_commit.tar.gz"
- 0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
- 0002-HID-apple-Properly-handle-function-keys-on-Keychron-.patch
)
validpgpkeys=(
- 'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
- '647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
+ ABAF11C65A2970B130ABE3C479BE3E4300411886 # Linus Torvalds
+ 647F28654894E3BD457199BE38DBBDC86092693E # Greg Kroah-Hartman
)
-sha256sums=('4e1c2a9e79847850029571a1dd04761e5f657b52c558070a085365641f133478'
+sha256sums=('f905f1238ea7a8e85314bacf283302e8097006010d25fcea726d0de0ea5bc9b6'
'SKIP'
- '382aa201a6a6939210dd8668ab052724547b4bd489b38e97502bbd0848061b35'
- '5a29d172d442a3f31a402d7d306aaa292b0b5ea29139d05080a55e2425f48c5c'
- '0506bdad4255ccc8165e39b2567450a3b12de2759ed7b42c0c90de1c57b1a283'
- '7294286511384aa7f7685b7f9cbe1d9729cc2ab8306541c9bdc6a521e2c92cb8'
- '15a2140a4bbf6b8ef32ddd6f7f65633c4af6aad9ca788c863d2d3fcfc0656fb2')
+ '4f1967a107ebdec0d5bbbb7d18ac1d61d40c0c9394d823b8fc52c8908a33b879'
+ '7a212eedb9fe3da99d6d5b63eb5f28c10ee4333e4d42ea1bb3842a15d3107bef'
+ '1d3ac3e581cbc5108f882fcdc75d74f7f069654c71bad65febe5ba15a7a3a14f'
+ '111adfc5b9c7d3bfd7d1a06286e7bee853dd1f51ecca3948eed39710eaf51381')
prepare() {
cd linux-${pkgver}
msg2 "Setting version..."
- scripts/setlocalversion --save-scmversion
echo "-$pkgrel" > localversion.10-pkgrel
echo "${pkgbase#linux}" > localversion.20-pkgname
- local src
- for src in "${source[@]}"; do
- src="${src%%::*}"
- src="${src##*/}"
- [[ $src = 0*.patch ]] || continue
- echo "Applying patch $src..."
- patch -Np1 < "../$src"
- done
+ msg2 "Applying Arch Linux $_upstream patch set"
+ patch -p1 -i ../linux-v$pkgver-$_upstream.patch || exit 1
+
+ # remove the -archx suffix
+ sed -i s'/^EXTRAVERSION =.*/EXTRAVERSION =/' Makefile
echo "Setting config..."
cp ../config .config
- # disable CONFIG_DEBUG_INFO=y at build time otherwise memory usage blows up
- # and can easily overwhelm a system with 32 GB of memory using a tmpfs build
- # partition ... this was introduced by FS#66260, see:
- # https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/linux&id=663b08666b269eeeeaafbafaee07fd03389ac8d7
- scripts/config --disable CONFIG_DEBUG_INFO
- scripts/config --disable CONFIG_CGROUP_BPF
- scripts/config --disable CONFIG_BPF_LSM
- scripts/config --disable CONFIG_BPF_PRELOAD
- scripts/config --disable CONFIG_BPF_LIRC_MODE2
- scripts/config --disable CONFIG_BPF_KPROBE_OVERRIDE
-
# https://bbs.archlinux.org/viewtopic.php?pid=1824594#p1824594
scripts/config --enable CONFIG_PSI_DEFAULT_DISABLED
@@ -170,8 +168,8 @@ prepare() {
# https://github.com/graysky2/kernel_gcc_patch
# make sure to apply after olddefconfig to allow the next section
- echo "Patching to enable GCC optimization for other uarchs..."
- patch -Np1 -i "$srcdir/kernel_compiler_patch-$_gcc_more_v/more-uarches-for-kernel-5.17+.patch"
+ msg2 "Patching to enable GCC optimization for other uarchs..."
+ patch -Np1 -i "$srcdir/kernel_compiler_patch-$_gcc_more_v/more-uarches-for-kernel-6.8-rc4+.patch"
if [ -n "$_subarch" ]; then
# user wants a subarch so apply choice defined above interactively via 'yes'
@@ -194,7 +192,7 @@ prepare() {
fi
make -s kernelrelease > version
- echo "Prepared $pkgbase version $(<version)"
+ msg2 "Prepared $pkgbase version $(<version)"
[[ -z "$_makenconfig" ]] || make LLVM=$_LLVM LLVM_IAS=$_LLVM nconfig
@@ -208,21 +206,33 @@ prepare() {
build() {
cd linux-${pkgver}
make LLVM=$_LLVM LLVM_IAS=$_LLVM all
+ make LLVM=$_LLVM LLVM_IAS=$_LLVM -C tools/bpf/bpftool vmlinux.h feature-clang-bpf-co-re=1
}
_package() {
pkgdesc="The Linux kernel and modules with ck's hrtimer patches"
- depends=(coreutils kmod initramfs)
- optdepends=('wireless-regdb: to set the correct wireless channels of your country'
- 'linux-firmware: firmware images needed for some devices')
- provides=(VIRTUALBOX-GUEST-MODULES WIREGUARD-MODULE)
- replaces=(virtualbox-guest-modules-arch wireguard-arch)
+ depends=(
+ coreutils
+ initramfs
+ kmod
+ )
+ optdepends=(
+ 'wireless-regdb: to set the correct wireless channels of your country'
+ 'linux-firmware: firmware images needed for some devices'
+ )
+ provides=(
+ KSMBD-MODULE
+ VIRTUALBOX-GUEST-MODULES
+ WIREGUARD-MODULE
+ )
+ replaces=(
+ virtualbox-guest-modules-arch
+ wireguard-arch
+ )
#groups=('ck-generic')
cd linux-${pkgver}
-
- local kernver="$(<version)"
- local modulesdir="$pkgdir/usr/lib/modules/$kernver"
+ local modulesdir="$pkgdir/usr/lib/modules/$(<version)"
echo "Installing boot image..."
# systemd expects to find the kernel here to allow hibernation
@@ -237,16 +247,16 @@ _package() {
echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
echo "Installing modules..."
- make LLVM=$_LLVM LLVM_IAS=$_LLVM INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 \
+ ZSTD_CLEVEL=19 make LLVM=$_LLVM LLVM_IAS=$_LLVM INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 \
DEPMOD=/doesnt/exist modules_install # Suppress depmod
- # remove build and source links
- rm "$modulesdir"/{source,build}
+ # remove build link
+ rm "$modulesdir"/build
}
_package-headers() {
pkgdesc="Headers and scripts for building modules for ${pkgbase/linux/Linux} kernel"
- depends=("$pkgbase") # added to keep kernel and headers packages matched
+ depends=(pahole "$pkgbase") # added to keep kernel and headers packages matched
#groups=('ck-generic')
cd linux-${pkgver}
@@ -254,7 +264,7 @@ _package-headers() {
echo "Installing build files..."
install -Dt "$builddir" -m644 .config Makefile Module.symvers System.map \
- localversion.* version vmlinux
+ localversion.* version vmlinux tools/bpf/bpftool/vmlinux.h
install -Dt "$builddir/kernel" -m644 kernel/Makefile
install -Dt "$builddir/arch/x86" -m644 arch/x86/Makefile
cp -t "$builddir" -a scripts
@@ -263,7 +273,7 @@ _package-headers() {
install -Dt "$builddir/tools/objtool" tools/objtool/objtool
# required when DEBUG_INFO_BTF_MODULES is enabled
- #install -Dt "$builddir/tools/bpf/resolve_btfids" tools/bpf/resolve_btfids/resolve_btfids
+ install -Dt "$builddir/tools/bpf/resolve_btfids" tools/bpf/resolve_btfids/resolve_btfids
echo "Installing headers..."
cp -t "$builddir" -a include
@@ -307,7 +317,7 @@ _package-headers() {
echo "Stripping build tools..."
local file
while read -rd '' file; do
- case "$(file -bi "$file")" in
+ case "$(file -Sib "$file")" in
application/x-sharedlib\;*) # Libraries (.so)
strip -v $STRIP_SHARED "$file" ;;
application/x-archive\;*) # Libraries (.a)
@@ -321,7 +331,6 @@ _package-headers() {
echo "Stripping vmlinux..."
strip -v $STRIP_STATIC "$builddir/vmlinux"
- # not needed since not building with CONFIG_DEBUG_INFO=y
echo "Adding symlink..."
mkdir -p "$pkgdir/usr/src"