summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD411
1 files changed, 214 insertions, 197 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 19d6d821363a..a0eba7e47498 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,267 +1,281 @@
-# Maintainer: graysky <graysky AT archlinux DOT us>
+# Maintainer: graysky <therealgraysky AT protonmail DOT com>
# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
-# Contributor: Tobias Powalowski <tpowa@archlinux.org>
-# Contributor: Thomas Baechler <thomas@archlinux.org>
### BUILD OPTIONS
-# Set these variables to ANYTHING that is not null to enable them
+# Any/all of the next three variables may be set to ANYTHING
+# that is not null to enable their respective build options
# Tweak kernel options prior to a build via nconfig
_makenconfig=
-# Optionally select a sub architecture by number if building in a clean chroot
-# Leaving this entry blank will require user interaction during the build
-# which will cause a failure to build if using makechrootpkg. Note that the
-# generic (default) option is 30.
-#
-# Note - the march=native option is unavailable by this method, use the nconfig
-# and manually select it.
-#
-# 1. AMD Opteron/Athlon64/Hammer/K8 (MK8)
-# 2. AMD Opteron/Athlon64/Hammer/K8 with SSE3 (MK8SSE3)
-# 3. AMD 61xx/7x50/PhenomX3/X4/II/K10 (MK10)
-# 4. AMD Barcelona (MBARCELONA)
-# 5. AMD Bobcat (MBOBCAT)
-# 6. AMD Jaguar (MJAGUAR)
-# 7. AMD Bulldozer (MBULLDOZER)
-# 8. AMD Piledriver (MPILEDRIVER)
-# 9. AMD Steamroller (MSTEAMROLLER)
-# 10. AMD Excavator (MEXCAVATOR)
-# 11. AMD Zen (MZEN)
-# 12. AMD Zen 2 (MZEN2)
-# 13. Intel P4 / older Netburst based Xeon (MPSC)
-# 14. Intel Atom (MATOM)
-# 15. Intel Core 2 (MCORE2)
-# 16. Intel Nehalem (MNEHALEM)
-# 17. Intel Westmere (MWESTMERE)
-# 18. Intel Silvermont (MSILVERMONT)
-# 19. Intel Goldmont (MGOLDMONT)
-# 20. Intel Goldmont Plus (MGOLDMONTPLUS)
-# 21. Intel Sandy Bridge (MSANDYBRIDGE)
-# 22. Intel Ivy Bridge (MIVYBRIDGE)
-# 23. Intel Haswell (MHASWELL)
-# 24. Intel Broadwell (MBROADWELL)
-# 25. Intel Skylake (MSKYLAKE)
-# 26. Intel Skylake X (MSKYLAKEX)
-# 27. Intel Cannon Lake (MCANNONLAKE)
-# 28. Intel Ice Lake (MICELAKE)
-# 29. Intel Cascade Lake (MCASCADELAKE)
-# 30. Generic-x86-64 (GENERIC_CPU)
-# 31. Native optimizations autodetected by GCC (MNATIVE)
-_subarch=
-
-# Compile ONLY used modules to VASTLYreduce the number of modules built
-# and the build time.
+# Only compile select modules to reduce the number of modules built
#
# To keep track of which modules are needed for your specific system/hardware,
-# give module_db script a try: https://aur.archlinux.org/packages/modprobed-db
-# This PKGBUILD read the database kept if it exists
-#
+# give module_db a try: https://aur.archlinux.org/packages/modprobed-db
+# This PKGBUILD reads the database kept if it exists
# More at this wiki page ---> https://wiki.archlinux.org/index.php/Modprobed-db
_localmodcfg=
-### IMPORTANT: Do no edit below this line unless you know what you're doing
+# Compile using clang rather than gcc
+_clangbuild=
+
+# Optionally select a sub architecture by number or leave blank which will
+# require user interaction during the build. Note that the generic (default)
+# option is 39.
+_subarch=
+
+# 1. AMD Opteron/Athlon64/Hammer/K8 (MK8)
+# 2. AMD Opteron/Athlon64/Hammer/K8 with SSE3 (MK8SSE3) (NEW)
+# 3. AMD 61xx/7x50/PhenomX3/X4/II/K10 (MK10) (NEW)
+# 4. AMD Barcelona (MBARCELONA) (NEW)
+# 5. AMD Bobcat (MBOBCAT) (NEW)
+# 6. AMD Jaguar (MJAGUAR) (NEW)
+# 7. AMD Bulldozer (MBULLDOZER) (NEW)
+# 8. AMD Piledriver (MPILEDRIVER) (NEW)
+# 9. AMD Steamroller (MSTEAMROLLER) (NEW)
+# 10. AMD Excavator (MEXCAVATOR) (NEW)
+# 11. AMD Zen (MZEN) (NEW)
+# 12. AMD Zen 2 (MZEN2) (NEW)
+# 13. AMD Zen 3 (MZEN3) (NEW)
+# 14. AMD Zen 4 (MZEN4) (NEW)
+# 15. Intel P4 / older Netburst based Xeon (MPSC)
+# 16. Intel Core 2 (MCORE2)
+# 17. Intel Atom (MATOM)
+# 18. Intel Nehalem (MNEHALEM) (NEW)
+# 19. Intel Westmere (MWESTMERE) (NEW)
+# 20. Intel Silvermont (MSILVERMONT) (NEW)
+# 21. Intel Goldmont (MGOLDMONT) (NEW)
+# 22. Intel Goldmont Plus (MGOLDMONTPLUS) (NEW)
+# 23. Intel Sandy Bridge (MSANDYBRIDGE) (NEW)
+# 24. Intel Ivy Bridge (MIVYBRIDGE) (NEW)
+# 25. Intel Haswell (MHASWELL) (NEW)
+# 26. Intel Broadwell (MBROADWELL) (NEW)
+# 27. Intel Skylake (MSKYLAKE) (NEW)
+# 28. Intel Skylake X (MSKYLAKEX) (NEW)
+# 29. Intel Cannon Lake (MCANNONLAKE) (NEW)
+# 30. Intel Ice Lake (MICELAKE) (NEW)
+# 31. Intel Cascade Lake (MCASCADELAKE) (NEW)
+# 32. Intel Cooper Lake (MCOOPERLAKE) (NEW)
+# 33. Intel Tiger Lake (MTIGERLAKE) (NEW)
+# 34. Intel Sapphire Rapids (MSAPPHIRERAPIDS) (NEW)
+# 35. Intel Rocket Lake (MROCKETLAKE) (NEW)
+# 36. Intel Alder Lake (MALDERLAKE) (NEW)
+# 37. Intel Raptor Lake (MRAPTORLAKE) (NEW)
+# 38. Intel Meteor Lake (MMETEORLAKE) (NEW)
+# 39. Generic-x86-64 (GENERIC_CPU)
+# 40. Generic-x86-64-v2 (GENERIC_CPU2) (NEW)
+# 41. Generic-x86-64-v3 (GENERIC_CPU3) (NEW)
+# 42. Generic-x86-64-v4 (GENERIC_CPU4) (NEW)
+# 43. Intel-Native optimizations autodetected by the compiler (MNATIVE_INTEL) (NEW)
+# 44. AMD-Native optimizations autodetected by the compiler (MNATIVE_AMD) (NEW)
+### IMPORTANT: Do no edit below this line unless you know what you're doing
pkgbase=linux-ck
-_srcver=5.2.15-arch1
-pkgver=${_srcver%-*}
-pkgrel=4
-_ckpatchversion=1
+pkgver=6.8.9
+_upstream=arch1
+pkgrel=1
arch=(x86_64)
url="https://wiki.archlinux.org/index.php/Linux-ck"
-license=(GPL2)
-makedepends=(kmod inetutils bc libelf)
-options=('!strip')
-_ckpatch="patch-5.2-ck${_ckpatchversion}"
-_gcc_more_v='20190822'
+license=(GPL-2.0-only)
+makedepends=(
+ bc
+ cpio
+ gettext
+ libelf
+ pahole
+ perl
+ python
+ tar
+ xz
+)
+[[ -n "$_clangbuild" ]] && makedepends+=(clang llvm lld python)
+options=(
+ !debug
+ !strip
+)
+
+# https://ck-hack.blogspot.com/2021/08/514-and-future-of-muqss-and-ck-once.html
+# acknowledgment to xanmod for initially keeping the hrtimer patches up to date
+_ckhrtimer=linux-6.8.y
+_commit=ae3cbb29c43ca1baa6781f547d17b8ee5663e9d7
+
+_gcc_more_v=20240221.2
source=(
- "https://www.kernel.org/pub/linux/kernel/v5.x/linux-$pkgver.tar".{xz,sign}
- config # the main kernel config file
- 60-linux.hook # pacman hook for depmod
- 90-linux.hook # pacman hook for initramfs regeneration
- linux.preset # standard config files for mkinitcpio ramdisk
- "enable_additional_cpu_optimizations-$_gcc_more_v.tar.gz::https://github.com/graysky2/kernel_gcc_patch/archive/$_gcc_more_v.tar.gz"
- "http://ck.kolivas.org/patches/5.0/5.2/5.2-ck${_ckpatchversion}/$_ckpatch.xz"
- 0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
- 0002-ZEN-Add-CONFIG-for-unprivileged_userns_clone.patch
+ "https://www.kernel.org/pub/linux/kernel/v6.x/linux-$pkgver.tar".{xz,sign}
+ config # the main kernel config file
+ "https://github.com/archlinux/linux/releases/download/v$pkgver-$_upstream/linux-v$pkgver-$_upstream.patch.zst"
+ "more-uarches-$_gcc_more_v.tar.gz::https://github.com/graysky2/kernel_compiler_patch/archive/$_gcc_more_v.tar.gz"
+ "ck-hrtimer-$_commit.tar.gz::https://github.com/graysky2/linux-patches/archive/$_commit.tar.gz"
)
validpgpkeys=(
- 'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
- '647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
+ ABAF11C65A2970B130ABE3C479BE3E4300411886 # Linus Torvalds
+ 647F28654894E3BD457199BE38DBBDC86092693E # Greg Kroah-Hartman
)
-sha256sums=('eb561009da8106b463b1e1a16ab0f75cdef564784f49177148f5f92c32380c4a'
+sha256sums=('f905f1238ea7a8e85314bacf283302e8097006010d25fcea726d0de0ea5bc9b6'
'SKIP'
- '42e2bc6a7d8439b3a6fe4084d1349077472e0a6831d8a39edda46824a5f0987b'
- 'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
- 'c043f3033bb781e2688794a59f6d1f7ed49ef9b13eb77ff9a425df33a244a636'
- 'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65'
- '8c11086809864b5cef7d079f930bd40da8d0869c091965fa62e95de9a0fe13b5'
- 'f1abc13a8d859fbf6350040e45d7f04ad551a6d39f113ba96fbbd820118c0e36'
- '91fafa76bf9cb32159ac7f22191b3589278b91e65bc4505cf2fc6013b8037bf3'
- '63e4378e69e2f23ed87af32a4951477a6d82d4ac0de2295db46502c8120da9d9')
-
-_kernelname=${pkgbase#linux}
-: ${_kernelname:=-ARCH}
+ '4f1967a107ebdec0d5bbbb7d18ac1d61d40c0c9394d823b8fc52c8908a33b879'
+ '7a212eedb9fe3da99d6d5b63eb5f28c10ee4333e4d42ea1bb3842a15d3107bef'
+ '1d3ac3e581cbc5108f882fcdc75d74f7f069654c71bad65febe5ba15a7a3a14f'
+ '111adfc5b9c7d3bfd7d1a06286e7bee853dd1f51ecca3948eed39710eaf51381')
prepare() {
cd linux-${pkgver}
msg2 "Setting version..."
- scripts/setlocalversion --save-scmversion
echo "-$pkgrel" > localversion.10-pkgrel
- echo "$_kernelname" > localversion.20-pkgname
-
- local src
- for src in "${source[@]}"; do
- src="${src%%::*}"
- src="${src##*/}"
- [[ $src = 00*.patch ]] || continue
- msg2 "Applying patch $src..."
- patch -Np1 < "../$src"
- done
+ echo "${pkgbase#linux}" > localversion.20-pkgname
+
+ msg2 "Applying Arch Linux $_upstream patch set"
+ patch -p1 -i ../linux-v$pkgver-$_upstream.patch || exit 1
- msg2 "Setting config..."
+ # remove the -archx suffix
+ sed -i s'/^EXTRAVERSION =.*/EXTRAVERSION =/' Makefile
+
+ echo "Setting config..."
cp ../config .config
# https://bbs.archlinux.org/viewtopic.php?pid=1824594#p1824594
- sed -i -e 's/# CONFIG_PSI_DEFAULT_DISABLED is not set/CONFIG_PSI_DEFAULT_DISABLED=y/' ./.config
+ scripts/config --enable CONFIG_PSI_DEFAULT_DISABLED
# https://bbs.archlinux.org/viewtopic.php?pid=1863567#p1863567
- sed -i -e '/CONFIG_LATENCYTOP=/ s,y,n,' \
- -i -e '/CONFIG_SCHED_DEBUG=/ s,y,n,' ./.config
+ scripts/config --disable CONFIG_LATENCYTOP
+ scripts/config --disable CONFIG_SCHED_DEBUG
+
+ # FS#66613
+ # https://bugzilla.kernel.org/show_bug.cgi?id=207173#c6
+ scripts/config --disable CONFIG_KVM_WERROR
- # fix naming schema in EXTRAVERSION of ck patch set
- sed -i -re "s/^(.EXTRAVERSION).*$/\1 = /" "../${_ckpatch}"
+ # ck recommends 1000 Hz tick and the hrtimer patches in lieu of ck1
+ scripts/config --enable CONFIG_HZ_1000
+
+ # these are ck's htrimer patches
+ echo "Patching with ck hrtimer patches..."
+
+ for i in ../linux-patches-"$_commit"/"$_ckhrtimer"/ck-hrtimer/0*.patch; do
+ patch -Np1 -i $i
+ done
+
+ if [[ -n "$_clangbuild" ]]; then
+ scripts/config -e LTO_CLANG_THIN
+ export _LLVM=1
+ export _LLVM_IAS=$_LLVM
+ fi
+
+ # non-interactively apply ck1 default options
+ # this isn't redundant if we want a clean selection of subarch below
+ make LLVM=$_LLVM LLVM_IAS=$_LLVM olddefconfig
+ diff -u ../config .config || :
- msg2 "Patching with ck patchset..."
- patch -Np1 -i ../"${_ckpatch}"
-
# https://github.com/graysky2/kernel_gcc_patch
- msg2 "Applying enable_additional_cpu_optimizations_for_gcc_v9.1+_kernel_v4.13+.patch ..."
- patch -Np1 -i "$srcdir/kernel_gcc_patch-$_gcc_more_v/enable_additional_cpu_optimizations_for_gcc_v9.1+_kernel_v4.13+.patch"
+ # make sure to apply after olddefconfig to allow the next section
+ msg2 "Patching to enable GCC optimization for other uarchs..."
+ patch -Np1 -i "$srcdir/kernel_compiler_patch-$_gcc_more_v/more-uarches-for-kernel-6.8-rc4+.patch"
if [ -n "$_subarch" ]; then
- yes "$_subarch" | make oldconfig
+ # user wants a subarch so apply choice defined above interactively via 'yes'
+ yes "$_subarch" | make LLVM=$_LLVM LLVM_IAS=$_LLVM oldconfig
else
- make prepare
+ # no subarch defined so allow user to pick one
+ make LLVM=$_LLVM LLVM_IAS=$_LLVM oldconfig
fi
### Optionally load needed modules for the make localmodconfig
# See https://aur.archlinux.org/packages/modprobed-db
if [ -n "$_localmodcfg" ]; then
if [ -f $HOME/.config/modprobed.db ]; then
- msg2 "Running Steven Rostedt's make localmodconfig now"
- make LSMOD=$HOME/.config/modprobed.db localmodconfig
+ echo "Running Steven Rostedt's make localmodconfig now"
+ make LLVM=$_LLVM LLVM_IAS=$_LLVM LSMOD="$HOME/.config/modprobed.db" localmodconfig
else
- msg2 "No modprobed.db data found"
+ echo "No modprobed.db data found"
exit
fi
fi
- # do not run `make olddefconfig` as it sets default options
- yes "" | make config >/dev/null
-
- make -s kernelrelease > ../version
- msg2 "Prepared %s version %s" "$pkgbase" "$(<../version)"
+ make -s kernelrelease > version
+ msg2 "Prepared $pkgbase version $(<version)"
- [[ -z "$_makenconfig" ]] || make nconfig
+ [[ -z "$_makenconfig" ]] || make LLVM=$_LLVM LLVM_IAS=$_LLVM nconfig
# save configuration for later reuse
cat .config > "${startdir}/config.last"
+
+ # uncomment if you want to build with distcc
+ ### sed -i '/HAVE_GCC_PLUGINS/d' arch/x86/Kconfig
}
build() {
cd linux-${pkgver}
- make bzImage modules
+ make LLVM=$_LLVM LLVM_IAS=$_LLVM all
+ make LLVM=$_LLVM LLVM_IAS=$_LLVM -C tools/bpf/bpftool vmlinux.h feature-clang-bpf-co-re=1
}
_package() {
- pkgdesc="The ${pkgbase/linux/Linux} kernel and modules with the ck1 patchset featuring MuQSS CPU scheduler"
- #_Kpkgdesc="The ${pkgbase/linux/Linux} kernel and modules with the ck1 patchset featuring MuQSS CPU scheduler"
- #pkgdesc="${_Kpkgdesc}"
- depends=(coreutils linux-firmware kmod mkinitcpio)
- optdepends=('crda: to set the correct wireless channels of your country')
- provides=("linux-ck=${pkgver}")
- backup=("etc/mkinitcpio.d/$pkgbase.preset")
- install=linux.install
+ pkgdesc="The Linux kernel and modules with ck's hrtimer patches"
+ depends=(
+ coreutils
+ initramfs
+ kmod
+ )
+ optdepends=(
+ 'wireless-regdb: to set the correct wireless channels of your country'
+ 'linux-firmware: firmware images needed for some devices'
+ )
+ provides=(
+ KSMBD-MODULE
+ VIRTUALBOX-GUEST-MODULES
+ WIREGUARD-MODULE
+ )
+ replaces=(
+ virtualbox-guest-modules-arch
+ wireguard-arch
+ )
#groups=('ck-generic')
- local kernver="$(<version)"
- local modulesdir="$pkgdir/usr/lib/modules/$kernver"
-
cd linux-${pkgver}
+ local modulesdir="$pkgdir/usr/lib/modules/$(<version)"
- msg2 "Installing boot image..."
+ echo "Installing boot image..."
# systemd expects to find the kernel here to allow hibernation
# https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
- install -Dm644 "$(make -s image_name)" "$modulesdir/vmlinuz"
- install -Dm644 "$modulesdir/vmlinuz" "$pkgdir/boot/vmlinuz-$pkgbase"
-
- msg2 "Installing modules..."
- make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
-
- # a place for external modules,
- # with version file for building modules and running depmod from hook
- local extramodules="extramodules$_kernelname"
- local extradir="$pkgdir/usr/lib/modules/$extramodules"
- install -Dt "$extradir" -m644 ../version
- ln -sr "$extradir" "$modulesdir/extramodules"
-
- # remove build and source links
- rm "$modulesdir"/{source,build}
-
- msg2 "Installing hooks..."
- # sed expression for following substitutions
- local subst="
- s|%PKGBASE%|$pkgbase|g
- s|%KERNVER%|$kernver|g
- s|%EXTRAMODULES%|$extramodules|g
- "
-
- # hack to allow specifying an initially nonexisting install file
- sed "$subst" "$startdir/$install" > "$startdir/$install.pkg"
- true && install=$install.pkg
-
- # fill in mkinitcpio preset and pacman hooks
- sed "$subst" ../linux.preset | install -Dm644 /dev/stdin \
- "$pkgdir/etc/mkinitcpio.d/$pkgbase.preset"
- sed "$subst" ../60-linux.hook | install -Dm644 /dev/stdin \
- "$pkgdir/usr/share/libalpm/hooks/60-$pkgbase.hook"
- sed "$subst" ../90-linux.hook | install -Dm644 /dev/stdin \
- "$pkgdir/usr/share/libalpm/hooks/90-$pkgbase.hook"
-
- msg2 "Fixing permissions..."
- chmod -Rc u=rwX,go=rX "$pkgdir"
+ #install -Dm644 "$(make -s image_name)" "$modulesdir/vmlinuz"
+ #
+ # hard-coded path in case user defined CC=xxx for build which causes errors
+ # see this FS https://bugs.archlinux.org/task/64315
+ install -Dm644 arch/x86/boot/bzImage "$modulesdir/vmlinuz"
+
+ # Used by mkinitcpio to name the kernel
+ echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
+
+ echo "Installing modules..."
+ ZSTD_CLEVEL=19 make LLVM=$_LLVM LLVM_IAS=$_LLVM INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 \
+ DEPMOD=/doesnt/exist modules_install # Suppress depmod
+
+ # remove build link
+ rm "$modulesdir"/build
}
_package-headers() {
- pkgdesc="Header files and scripts for building modules for ${pkgbase/linux/Linux} kernel"
- #_Hpkgdesc="Header files and scripts for building modules for ${pkgbase/linux/Linux} kernel"
- #pkgdesc="${_Hpkgdesc}"
- depends=('linux-ck') # added to keep kernel and headers packages matched
- provides=("linux-ck-headers=${pkgver}" "linux-headers=${pkgver}")
+ pkgdesc="Headers and scripts for building modules for ${pkgbase/linux/Linux} kernel"
+ depends=(pahole "$pkgbase") # added to keep kernel and headers packages matched
#groups=('ck-generic')
- local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
-
cd linux-${pkgver}
+ local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
- msg2 "Installing build files..."
- install -Dt "$builddir" -m644 Makefile .config Module.symvers System.map vmlinux
+ echo "Installing build files..."
+ install -Dt "$builddir" -m644 .config Makefile Module.symvers System.map \
+ localversion.* version vmlinux tools/bpf/bpftool/vmlinux.h
install -Dt "$builddir/kernel" -m644 kernel/Makefile
install -Dt "$builddir/arch/x86" -m644 arch/x86/Makefile
cp -t "$builddir" -a scripts
- # add objtool for external module building and enabled VALIDATION_STACK option
+ # required when STACK_VALIDATION is enabled
install -Dt "$builddir/tools/objtool" tools/objtool/objtool
- # add xfs and shmem for aufs building
- mkdir -p "$builddir"/{fs/xfs,mm}
+ # required when DEBUG_INFO_BTF_MODULES is enabled
+ install -Dt "$builddir/tools/bpf/resolve_btfids" tools/bpf/resolve_btfids/resolve_btfids
- # ???
- mkdir "$builddir/.tmp_versions"
-
- msg2 "Installing headers..."
+ echo "Installing headers..."
cp -t "$builddir" -a include
cp -t "$builddir/arch/x86" -a arch/x86/include
install -Dt "$builddir/arch/x86/kernel" -m644 arch/x86/kernel/asm-offsets.s
@@ -269,18 +283,21 @@ _package-headers() {
install -Dt "$builddir/drivers/md" -m644 drivers/md/*.h
install -Dt "$builddir/net/mac80211" -m644 net/mac80211/*.h
- # http://bugs.archlinux.org/task/13146
+ # https://bugs.archlinux.org/task/13146
install -Dt "$builddir/drivers/media/i2c" -m644 drivers/media/i2c/msp3400-driver.h
- # http://bugs.archlinux.org/task/20402
+ # https://bugs.archlinux.org/task/20402
install -Dt "$builddir/drivers/media/usb/dvb-usb" -m644 drivers/media/usb/dvb-usb/*.h
install -Dt "$builddir/drivers/media/dvb-frontends" -m644 drivers/media/dvb-frontends/*.h
install -Dt "$builddir/drivers/media/tuners" -m644 drivers/media/tuners/*.h
- msg2 "Installing KConfig files..."
+ # https://bugs.archlinux.org/task/71392
+ install -Dt "$builddir/drivers/iio/common/hid-sensors" -m644 drivers/iio/common/hid-sensors/*.h
+
+ echo "Installing KConfig files..."
find . -name 'Kconfig*' -exec install -Dm644 {} "$builddir/{}" \;
- msg2 "Removing unneeded architectures..."
+ echo "Removing unneeded architectures..."
local arch
for arch in "$builddir"/arch/*/; do
[[ $arch = */x86/ ]] && continue
@@ -288,19 +305,19 @@ _package-headers() {
rm -r "$arch"
done
- msg2 "Removing documentation..."
+ echo "Removing documentation..."
rm -r "$builddir/Documentation"
- msg2 "Removing broken symlinks..."
+ echo "Removing broken symlinks..."
find -L "$builddir" -type l -printf 'Removing %P\n' -delete
- msg2 "Removing loose objects..."
+ echo "Removing loose objects..."
find "$builddir" -type f -name '*.o' -printf 'Removing %P\n' -delete
- msg2 "Stripping build tools..."
+ echo "Stripping build tools..."
local file
while read -rd '' file; do
- case "$(file -bi "$file")" in
+ case "$(file -Sib "$file")" in
application/x-sharedlib\;*) # Libraries (.so)
strip -v $STRIP_SHARED "$file" ;;
application/x-archive\;*) # Libraries (.a)
@@ -312,12 +329,12 @@ _package-headers() {
esac
done < <(find "$builddir" -type f -perm -u+x ! -name vmlinux -print0)
- msg2 "Adding symlink..."
- mkdir -p "$pkgdir/usr/src"
- ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase-$pkgver"
+ echo "Stripping vmlinux..."
+ strip -v $STRIP_STATIC "$builddir/vmlinux"
- msg2 "Fixing permissions..."
- chmod -Rc u=rwX,go=rX "$pkgdir"
+ echo "Adding symlink..."
+ mkdir -p "$pkgdir/usr/src"
+ ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase"
}
pkgname=("$pkgbase" "$pkgbase-headers")