summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 11 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c9ef8b721515..1c3cb282e710 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -68,13 +68,13 @@ _subarch=
### IMPORTANT: Do no edit below this line unless you know what you're doing
pkgbase=linux-ck
-pkgver=6.1
+pkgver=6.1.1
pkgrel=1
arch=(x86_64)
url="https://wiki.archlinux.org/index.php/Linux-ck"
license=(GPL2)
makedepends=(
- bc libelf cpio perl tar xz
+ bc libelf pahole cpio perl tar xz
)
[[ -n "$_clangbuild" ]] && makedepends+=(clang llvm lld python)
options=('!strip')
@@ -84,7 +84,7 @@ options=('!strip')
_ckhrtimer=linux-6.1.y
_commit=fdbdf7e0ec56cd59e11d024c473e766429271a5c
-_gcc_more_v=20221104
+_gcc_more_v=20221217
source=(
"https://www.kernel.org/pub/linux/kernel/v6.x/linux-$pkgver.tar".{xz,sign}
config # the main kernel config file
@@ -92,18 +92,20 @@ source=(
"ck-hrtimer-$_commit.tar.gz::https://github.com/graysky2/linux-patches/archive/$_commit.tar.gz"
0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
0002-drm-i915-improve-the-catch-all-evict-to-handle-lock-.patch
+ 0003-futex-Resend-potentially-swallowed-owner-death-notif.patch
)
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
)
-sha256sums=('2ca1f17051a430f6fed1196e4952717507171acfd97d96577212502703b25deb'
+sha256sums=('a3e61377cf4435a9e2966b409a37a1056f6aaa59e561add9125a88e3c0971dfb'
'SKIP'
'0571ea17a2e38458096b679418197bbea8c414388f628d122517f3a1f3a31b3a'
- '3a8f397b89bad95c46f42c0f80ede7536a4a45a28621e00ed486918a55f905ed'
+ 'f1d586e111932890ad5e0df15d092fb9b3f87bae4ea17812aae9b0ec98fe2db0'
'6d3b9cb4639c1c5eb4e2697aed0dbffa5b4a37d63a0861dec8315dd052723e0e'
- '01f0f3d1b79fd789e01ba5debb3b63e9716679199b6fd79e81744d688632e273'
- 'a3dc6156ca04fef849662a8febd2ebc7ca175de54253ef293f4c8ce638149507')
+ '865fa8cc41186a42225e89c845d438aefae6332d1ef18b94ef3aae04deb5e784'
+ '9c6191b355fcaf41cfeb92105ea0d24bbc51c993877d3fb5325f139997ede058'
+ '748e40e3a4b889850e8f86aee7ff96a93d43476a6529316bd823e18e23fc82f8')
prepare() {
cd linux-${pkgver}
@@ -125,17 +127,6 @@ prepare() {
echo "Setting config..."
cp ../config .config
- # disable CONFIG_DEBUG_INFO=y at build time otherwise memory usage blows up
- # and can easily overwhelm a system with 32 GB of memory using a tmpfs build
- # partition ... this was introduced by FS#66260, see:
- # https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/linux&id=663b08666b269eeeeaafbafaee07fd03389ac8d7
- scripts/config --disable CONFIG_DEBUG_INFO
- scripts/config --disable CONFIG_CGROUP_BPF
- scripts/config --disable CONFIG_BPF_LSM
- scripts/config --disable CONFIG_BPF_PRELOAD
- scripts/config --disable CONFIG_BPF_LIRC_MODE2
- scripts/config --disable CONFIG_BPF_KPROBE_OVERRIDE
-
# https://bbs.archlinux.org/viewtopic.php?pid=1824594#p1824594
scripts/config --enable CONFIG_PSI_DEFAULT_DISABLED
@@ -246,7 +237,7 @@ _package() {
_package-headers() {
pkgdesc="Headers and scripts for building modules for ${pkgbase/linux/Linux} kernel"
- depends=("$pkgbase") # added to keep kernel and headers packages matched
+ depends=(pahole "$pkgbase") # added to keep kernel and headers packages matched
#groups=('ck-generic')
cd linux-${pkgver}
@@ -263,7 +254,7 @@ _package-headers() {
install -Dt "$builddir/tools/objtool" tools/objtool/objtool
# required when DEBUG_INFO_BTF_MODULES is enabled
- #install -Dt "$builddir/tools/bpf/resolve_btfids" tools/bpf/resolve_btfids/resolve_btfids
+ install -Dt "$builddir/tools/bpf/resolve_btfids" tools/bpf/resolve_btfids/resolve_btfids
echo "Installing headers..."
cp -t "$builddir" -a include