summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD57
1 files changed, 27 insertions, 30 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6843da84eed8..bb1bc077cbf0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -35,27 +35,27 @@ _makenconfig=
# 16. Intel Nehalem (MNEHALEM)
# 17. Intel Westmere (MWESTMERE)
# 18. Intel Silvermont (MSILVERMONT)
-# 19. Intel Sandy Bridge (MSANDYBRIDGE)
-# 20. Intel Ivy Bridge (MIVYBRIDGE)
-# 21. Intel Haswell (MHASWELL)
-# 22. Intel Broadwell (MBROADWELL)
-# 23. Intel Skylake (MSKYLAKE)
-# 24. Intel Skylake X (MSKYLAKEX)
-# 25. Intel Cannon Lake (MCANNONLAKE)
-# 26. Intel Ice Lake (MICELAKE)
-# 27. Generic-x86-64 (GENERIC_CPU)
-# 28. Native optimizations autodetected by GCC (MNATIVE)
+# 19. Intel Goldmont (MGOLDMONT)
+# 20. Intel Goldmont Plus (MGOLDMONTPLUS)
+# 21. Intel Sandy Bridge (MSANDYBRIDGE)
+# 22. Intel Ivy Bridge (MIVYBRIDGE)
+# 23. Intel Haswell (MHASWELL)
+# 24. Intel Broadwell (MBROADWELL)
+# 25. Intel Skylake (MSKYLAKE)
+# 26. Intel Skylake X (MSKYLAKEX)
+# 27. Intel Cannon Lake (MCANNONLAKE)
+# 28. Intel Ice Lake (MICELAKE)
+# 29. Intel Cascade Lake (MCASCADELAKE)
+# 30. Generic-x86-64 (GENERIC_CPU)
+# 31. Native optimizations autodetected by GCC (MNATIVE)
_subarch=
-# Compile ONLY probed modules
-# Build in only the modules that you currently have probed in your system VASTLY
-# reducing the number of modules built and the build time.
-#
-# WARNING - ALL modules must be probed BEFORE you begin making the pkg!
+# Compile ONLY used modules to VASTLYreduce the number of modules built
+# and the build time.
#
# To keep track of which modules are needed for your specific system/hardware,
# give module_db script a try: https://aur.archlinux.org/packages/modprobed-db
-# This PKGBUILD will call it directly to probe all the modules you have logged!
+# This PKGBUILD read the database kept if it exists
#
# More at this wiki page ---> https://wiki.archlinux.org/index.php/Modprobed-db
_localmodcfg=
@@ -63,7 +63,7 @@ _localmodcfg=
### IMPORTANT: Do no edit below this line unless you know what you're doing
pkgbase=linux-ck
-_srcver=5.2.9-arch1
+_srcver=5.2.10-arch1
pkgver=${_srcver%-*}
pkgrel=1
_ckpatchversion=1
@@ -73,7 +73,7 @@ license=(GPL2)
makedepends=(kmod inetutils bc libelf)
options=('!strip')
_ckpatch="patch-5.2-ck${_ckpatchversion}"
-_gcc_more_v='20190714'
+_gcc_more_v='20190822'
source=(
"https://www.kernel.org/pub/linux/kernel/v5.x/linux-$pkgver.tar".{xz,sign}
config # the main kernel config file
@@ -85,24 +85,22 @@ source=(
0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
0002-ZEN-Add-CONFIG-for-unprivileged_userns_clone.patch
0003-iwlwifi-mvm-disable-TX-AMSDU-on-older-NICs.patch
- 0004-iwlwifi-Add-support-for-SAR-South-Korea-limitation.patch
)
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
)
-sha256sums=('b6f02a4b306ca5cd314d72615bfc2650166969613135da202630e6c4e1b5d4e6'
+sha256sums=('6096c4387c2a296de9136080942d11ae3f1bd28129b6952f7133c570e43bfc49'
'SKIP'
'1c4d5500a3b4995035c2e940fc0ad2a2dae7be047c8eb20c097444e348258f87'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'c043f3033bb781e2688794a59f6d1f7ed49ef9b13eb77ff9a425df33a244a636'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65'
- '2466fb4aecc66d1b258b4cbdb2f215b5099f266d8c4386bb62ad1a0acd0caf5b'
+ '8c11086809864b5cef7d079f930bd40da8d0869c091965fa62e95de9a0fe13b5'
'f1abc13a8d859fbf6350040e45d7f04ad551a6d39f113ba96fbbd820118c0e36'
'91fafa76bf9cb32159ac7f22191b3589278b91e65bc4505cf2fc6013b8037bf3'
'63e4378e69e2f23ed87af32a4951477a6d82d4ac0de2295db46502c8120da9d9'
- 'fc96300831506965383ef30bc46b72735dc45bb97dea2ccb8b9450c005d2f020'
- 'ef926edbd866d95464eb86f7565de572eb97ecfa0369d3b2e078016a0e71a871')
+ 'fc96300831506965383ef30bc46b72735dc45bb97dea2ccb8b9450c005d2f020')
_kernelname=${pkgbase#linux}
: ${_kernelname:=-ARCH}
@@ -149,13 +147,12 @@ prepare() {
### Optionally load needed modules for the make localmodconfig
# See https://aur.archlinux.org/packages/modprobed-db
if [ -n "$_localmodcfg" ]; then
- msg "If you have modprobed-db installed, running it in recall mode now"
- if [ -e /usr/bin/modprobed-db ]; then
- [[ -x /usr/bin/sudo ]] || {
- echo "Cannot call modprobe with sudo. Install sudo and configure it to work with this user."
- exit 1; }
- sudo /usr/bin/modprobed-db recall
- make localmodconfig
+ if [ -f $HOME/.config/modprobed.db ]; then
+ msg2 "Running Steven Rostedt's make localmodconfig now"
+ make LSMOD=$HOME/.config/modprobed.db localmodconfig
+ else
+ msg2 "No modprobed.db data found"
+ exit1
fi
fi