summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fb603db087d9..19c094e658de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -53,13 +53,13 @@ pkgname=(linux-ck linux-ck-headers)
_kernelname=-ck
_srcname=linux-4.7
pkgver=4.7.4
-pkgrel=1
+pkgrel=2
arch=('i686' 'x86_64')
url="https://wiki.archlinux.org/index.php/Linux-ck"
license=('GPL2')
makedepends=('kmod' 'inetutils' 'bc' 'libelf')
options=('!strip')
-_ckpatchversion=4
+_ckpatchversion=5
_ckpatchname="patch-4.7-ck${_ckpatchversion}"
_gcc_patch='enable_additional_cpu_optimizations_for_gcc_v4.9+_kernel_v3.15+.patch'
_bfqpath='http://algo.ing.unimo.it/people/paolo/disk_sched/patches/4.7.0-v8r3'
@@ -91,7 +91,7 @@ sha256sums=('5190c3d1209aeda04168145bf50569dc0984f80467159b1dc50ad731e3285f10'
'2bf031f11b4ea0a9a11876a28836b777fa055be38908fc5101f622bdeb27e72d'
'2b3ebf5446aa3cac279842ca00bc1f2d6b7ff1766915282c201d763dbf6ca07e'
'1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99'
- 'b9eae0f9aa54a41a6d5a3613c814b207fd2396a198af4a3bcd93be17f2f1bbd4'
+ '1cf066cbad338f64a315e455b38d29dd509b20a16bfb6e2faa1766f776fd335f'
'cf0f984ebfbb8ca8ffee1a12fd791437064b9ebe0712d6f813fd5681d4840791'
'a6bd81bbb2f72cfd6ad992fdeff4bac1cb7c58a8edfc3fcd76c1d7275f73d284'
'144b54e95a1ffca88066e41f3c46c47df442d6497684e204e9f4312faab75572'
@@ -116,7 +116,7 @@ prepare() {
# patch source with ck patchset with BFS
# fix double name in EXTRAVERSION
sed -i -re "s/^(.EXTRAVERSION).*$/\1 = /" "${srcdir}/${_ckpatchname}"
- msg "Patching source with ck4 including BFS v0.497"
+ msg "Patching source with ck5 including BFS v0.502"
patch -Np1 -i "${srcdir}/${_ckpatchname}"
# Patch source to enable more gcc CPU optimizatons via the make nconfig
@@ -241,8 +241,8 @@ build() {
}
package_linux-ck() {
- pkgdesc='Linux Kernel with the ck4 patchset featuring the Brain Fuck Scheduler v0.497.'
- #_Kpkgdesc='Linux Kernel and modules with the ck4 patchset featuring the Brain Fuck Scheduler v0.497.'
+ pkgdesc='Linux Kernel with the ck5 patchset featuring the Brain Fuck Scheduler v0.502.'
+ #_Kpkgdesc='Linux Kernel and modules with the ck5 patchset featuring the Brain Fuck Scheduler v0.502.'
#pkgdesc="${_Kpkgdesc}"
depends=('coreutils' 'linux-firmware' 'mkinitcpio>=0.7')
optdepends=('crda: to set the correct wireless channels of your country' 'nvidia-ck: nVidia drivers for linux-ck' 'modprobed-db: Keeps track of EVERY kernel module that has ever been probed - useful for those of us who make localmodconfig')