summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 7 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f93c91947c60..49d3570e9855 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -53,13 +53,13 @@ pkgname=(linux-ck linux-ck-headers)
_kernelname=-ck
_srcname=linux-4.3
pkgver=4.3.1
-pkgrel=2
+pkgrel=3
arch=('i686' 'x86_64')
url="https://wiki.archlinux.org/index.php/Linux-ck"
license=('GPL2')
makedepends=('kmod' 'inetutils' 'bc')
options=('!strip')
-_ckpatchversion=1
+_ckpatchversion=2
_ckpatchname="patch-4.3-ck${_ckpatchversion}"
_gcc_patch="enable_additional_cpu_optimizations_for_gcc_v4.9+_kernel_v3.15+.patch"
_bfqpath="http://algo.ing.unimo.it/people/paolo/disk_sched/patches/4.3.0-v7r8"
@@ -70,9 +70,8 @@ source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
'config.x86_64' 'config'
'linux-ck.preset'
'change-default-console-loglevel.patch'
-# ck1
+# ck2
"http://ck.kolivas.org/patches/4.0/4.3/4.3-ck${_ckpatchversion}/${_ckpatchname}.xz"
-"http://ck.kolivas.org/patches/bfs/4.0/4.3/Pending/bfs465-nohz-buildfix.patch"
# gcc
"http://repo-ck.com/source/gcc_patch/${_gcc_patch}.gz"
# bfq
@@ -87,8 +86,7 @@ sha256sums=('4a622cc84b8a3c38d39bc17195b0c064d2b46945dfde0dae18f77b120bc9f3ae'
'8e83d9306376750632e87bed77d4caf3475a4390a8f6673d58ee959b3722f12c'
'2b3ebf5446aa3cac279842ca00bc1f2d6b7ff1766915282c201d763dbf6ca07e'
'1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99'
- '01961bedc08ae3def15050e107092cba39361f6d5402049a36ff9aa0fbf328a3'
- '3c5eccbcf6159f7e8e66f8ecc062524e89fde8ebaafda503b34be87fa6cb6588'
+ 'efd397f975cc79aabd2914ec331bdaeef9927b3c038a3f682c72b7a6e13feb64'
'cf0f984ebfbb8ca8ffee1a12fd791437064b9ebe0712d6f813fd5681d4840791'
'ebeb62206999b2749ac43bb287a6a2a5db4f6b1b688a90cefa1ceb5db94aa490'
'91b7cb42b8337b768e5329da205a6b61211628ec99b1e308e0e9d5283b2c86eb'
@@ -112,9 +110,8 @@ prepare() {
# patch source with ck patchset with BFS
# fix double name in EXTRAVERSION
sed -i -re "s/^(.EXTRAVERSION).*$/\1 = /" "${srcdir}/${_ckpatchname}"
- msg "Patching source with ck1 including BFS v0.465"
+ msg "Patching source with ck2 including BFS v0.466"
patch -Np1 -i "${srcdir}/${_ckpatchname}"
- patch -Np1 -i "${srcdir}/bfs465-nohz-buildfix.patch"
# Patch source to enable more gcc CPU optimizatons via the make nconfig
msg "Patching source with gcc patch to enable more cpus types"
@@ -237,8 +234,8 @@ build() {
}
package_linux-ck() {
- pkgdesc='Linux Kernel with the ck1 patchset featuring the Brain Fuck Scheduler v0.465.'
- #_Kpkgdesc='Linux Kernel and modules with the ck1 patchset featuring the Brain Fuck Scheduler v0.465.'
+ pkgdesc='Linux Kernel with the ck2 patchset featuring the Brain Fuck Scheduler v0.466.'
+ #_Kpkgdesc='Linux Kernel and modules with the ck2 patchset featuring the Brain Fuck Scheduler v0.466.'
#pkgdesc="${_Kpkgdesc}"
depends=('coreutils' 'linux-firmware' 'mkinitcpio>=0.7')
optdepends=('crda: to set the correct wireless channels of your country' 'nvidia-ck: nVidia drivers for linux-ck' 'modprobed-db: Keeps track of EVERY kernel module that has ever been probed - useful for those of us who make localmodconfig')