summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 17 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index df53f78333e4..d643cbaaa715 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
set -u
pkgbase="linux-lts414"
-pkgver="4.14.175"
+pkgver="4.14.176"
_srcname="linux-${pkgver%.*}"
pkgrel='1'
arch=('x86_64')
@@ -19,8 +19,11 @@ source=(
'60-linux.hook' # pacman hook for depmod
'90-linux.hook' # pacman hook for initramfs regeneration
'linux-lts.preset' # standard config files for mkinitcpio ramdisk
+ # disable USER_NS for non-root users by default
'0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch'
+ # https://bugs.archlinux.org/task/56711
'0003-Revert-drm-i915-edp-Allow-alternate-fixed-mode-for-e.patch'
+ # https://github.com/NixOS/nixpkgs/pull/61076
'0004-export_kernel_fpu_functions.patch'
)
validpgpkeys=(
@@ -29,7 +32,7 @@ validpgpkeys=(
)
# https://www.kernel.org/pub/linux/kernel/v4.x/sha256sums.asc
md5sums=('bacdb9ffdcd922aa069a5e1520160e24'
- '18f4a648b7c49ac2c305b17be854b313'
+ 'a4809f314ae2f7b5fc99aba866f3c9d3'
'e0400bf4a229af8a187f00a926cb3e96'
'ce6c81ad1ad1f8b333fd6077d47abdaf'
'a85bfae59eb537b973c388ffadb281ff'
@@ -38,7 +41,7 @@ md5sums=('bacdb9ffdcd922aa069a5e1520160e24'
'95204750f94a5f6d2d19e021736265d5'
'f7d76cdef5cf4ac6a49115fc4f1f35d5')
sha256sums=('f81d59477e90a130857ce18dc02f4fbe5725854911db1e7ba770c7cd350f96a7'
- '6a907b581f056158f6d68e508d50f2391cc6f0f15278e98b08a352ad7402bbc0'
+ '7d54ac0c9954c70771ef10f4926f5a5e2658b0bbc73612778c82163c02d309cf'
'837f66e63c96701962a483f23de6b2b4bcc33dac2a697ffbdcf155c0adb864fb'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
@@ -72,14 +75,17 @@ prepare() {
# add latest fixes from stable queue, if needed
# http://git.kernel.org/?p=linux/kernel/git/stable/stable-queue.git
- # disable USER_NS for non-root users by default
- patch -Nup1 -i ../0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
-
- # https://bugs.archlinux.org/task/56711
- patch -Nup1 -i ../0003-Revert-drm-i915-edp-Allow-alternate-fixed-mode-for-e.patch
-
- # https://github.com/NixOS/nixpkgs/pull/61076
- patch -Nup1 -i '../0004-export_kernel_fpu_functions.patch'
+ local _f
+ for _f in "${source[@]}"; do
+ _f="${_f%%::*}"
+ _f="${_f##*/}"
+ case "${_f}" in
+ *.patch)
+ set +u; msg2 "Patch ${_f}"; set +u
+ patch -Nup1 -i "${srcdir}/${_f}"
+ ;;
+ esac
+ done
# Local or private patches
shopt -s nullglob