summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 10 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d2f6a6096e4d..4c64d02bd343 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,22 @@
+# Maintainer: Julia DeMille <me@jdemille.com>
+# Contributor: David <ottodavid@gmx.net>
pkgname=linvst
-pkgver=2.8.r98.e0c8d55
+pkgver=4.7
pkgrel=1
license=('GPL3')
-pkgdesc="enables Windows vst's to be used as Linux vst's in Linux vst capable DAW's"
+pkgdesc="Windows VST2 wrapper that allows them to be used as Linux VST2s in compatible DAWs using Wine."
arch=('x86_64')
url="https://github.com/osxmidi/LinVst"
depends=('wine')
-makedepends=('git')
-source=('git+https://github.com/osxmidi/LinVst.git' 'https://download.steinberg.net/sdk_downloads/vstsdk3611_22_10_2018_build_34.zip')
-sha256sums=('SKIP'
- 'de64ff1b5b40a7fdc2de873e80d911ffa9fd6b82435a555dda1e8edc267d1fa3')
-
-pkgver() {
- cd "LinVst"
- printf "%s" "$(git describe --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
-}
-
-prepare() {
- ln -sf "${srcdir}/VST_SDK/VST2_SDK/pluginterfaces" "LinVst/"
-}
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/osxmidi/LinVst/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('96cf075eebb9db4d23f6fe7327b70496320f3d751e5ec24b7ffa3e29c750c8d1')
build() {
- cd "${srcdir}/LinVst"
- make -f Makefile-64-32bit DESTDIR="${pkgdir}" all
+ cd "${srcdir}/LinVst-${pkgver}"
+ make DESTDIR="${pkgdir}" all
}
package() {
- cd "${srcdir}/LinVst"
- make -f Makefile-64-32bit DESTDIR="${pkgdir}" VST_DIR="${pkgdir}/usr/lib/vst/" install
+ cd "${srcdir}/LinVst-${pkgver}"
+ make DESTDIR="${pkgdir}" VST_DIR="${pkgdir}/usr/lib/vst/" install
}