summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..12ad0816a706
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Dusan Baran <work.dusanbaran@gmail.com>
+
+_pkgname=litify
+pkgname=litify-git
+pkgver=96590e0
+pkgrel=1
+pkgdesc="LITify git"
+arch=('any')
+url="https://github.com/dudoslav/${_pkgname}"
+license=('GPL3')
+depends=('git'
+ 'pacman')
+optdepends=('noto-fonts-emoji'
+ 'unicode-emoji')
+source=("git+https://github.com/dudoslav/${_pkgname}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --always | sed -e 's|-|.|g'
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ install -m 755 -D "$_pkgname" "$pkgdir/usr/bin/$_pkgname"
+ install -m 644 -D 'lit' "$pkgdir/etc/lit"
+}
+