summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 11 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8d785de810f2..f58763f30565 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,8 @@
pkgname=logmein-hamachi-beta
_pkgname=logmein-hamachi
-pkgver=2.1.0.189
-pkgrel=2
+pkgver=2.1.0.198
+pkgrel=3
pkgdesc="A zero-configuration VPN service with glibc 2.26 support, beta version"
arch=("i686" "x86_64" "arm" "armv6h" "armv7h")
url="https://www.vpn.net/linux"
@@ -18,18 +18,15 @@ conflicts=("logmein-hamachi")
options=("!strip")
sha1sums=('2b8052f91bb47beac1fdab0c0c455a36f8876671')
-[ "${CARCH}" == "i686" ] && _filearch_=x86 && sha1sums+=('d0547257141f5c9446df1abc1820e45584781d32')
-[ "${CARCH}" == "x86_64" ] && _filearch_=x64 && sha1sums+=('edb49508470252b6d95ce3eabeb7c9c86ad3fbfa')
-[ "${CARCH}" == "arm" ] && _filearch_=armel && sha1sums+=('e980a86f5d658d51622533560305057116a06df6')
-[ "${CARCH}" == "armv6h" ] && _filearch_=armel && sha1sums+=('e980a86f5d658d51622533560305057116a06df6')
-[ "${CARCH}" == "armv7h" ] && _filearch_=armhf && sha1sums+=('2b64ae08808c90877a302e5090a2cdd3cf7e5f13')
-
-source=("logmein-hamachi-beta.service")
-if [ "${CARCH}" == "i686" ] || [ "${CARCH}" == "x86_64" ]; then
- source+=("https://www.vpn.net/installers/${_pkgname}-${pkgver}-${_filearch_}_beta.tgz")
-elif [ "${CARCH}" == "arm" ] || [ "${CARCH}" == "armv6h" ] || [ "${CARCH}" == "armv7h" ]; then
- source+=("https://www.vpn.net/installers/${_pkgname}-${pkgver}-${_filearch_}.tgz")
-fi
+[ "${CARCH}" == "i686" ] && _filearch_=x86 && sha1sums+=('4070960416602dc805400c080e53bee3794d5a13')
+[ "${CARCH}" == "x86_64" ] && _filearch_=x64 && sha1sums+=('235806bf8eecf79da054ffe253150772c677c73c')
+[ "${CARCH}" == "arm" ] && _filearch_=armel && sha1sums+=('24efae6a1255763b2fe9f6fa08ab8e9594c6bf8b')
+[ "${CARCH}" == "armv6h" ] && _filearch_=armel && sha1sums+=('24efae6a1255763b2fe9f6fa08ab8e9594c6bf8b')
+[ "${CARCH}" == "armv7h" ] && _filearch_=armhf && sha1sums+=('2c9055351e77f45a20be9ebf989ead23567e21b0')
+
+source=("logmein-hamachi-beta.service"
+ "https://www.vpn.net/installers/${_pkgname}-${pkgver}-${_filearch_}.tgz")
+
package() {
cd "${srcdir}"/${_pkgname}-${pkgver}-${_filearch_}