summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b980d34af08c..83775f3786e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
#!/usr/bin/env bash
# Maintainer: Joshua Hoeflich
pkgname=lsr-git
+__repo_name__=lsr
pkgver=main
pkgrel=1
-pkgdesc="List files recursively."
+pkgdesc="Recursively list files in directories."
arch=('x86_64')
url="https://github.com/joshuahoeflich/lsr"
license=('MIT')
@@ -18,17 +19,17 @@ backup=()
options=()
install=
changelog=
-source=("https://github.com/joshuahoeflich/lsr/archive/main.tar.gz")
+source=("https://github.com/joshuahoeflich/${__repo_name__}/archive/main.tar.gz")
noextract=()
md5sums=('da8293111d8ae975b31bceeab71e89d5')
build() {
- cd "$pkgname-$pkgver"
+ cd "${__repo_name__}-$pkgver"
cargo build --release
}
package() {
- cd "$pkgname-$pkgver"
+ cd "${__repo_name__}-$pkgver"
mkdir -p "$pkgdir"/usr/bin
cp target/release/lsr "$pkgdir"/usr/bin
}