summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f06dcab0f9db..f66810a12a47 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,17 @@
_luaname=epnf
_rockname=lua$_luaname
-pkgname=("lua-$_rockname" "lua52-$_rockname" "lua51-$_rockname")
+pkgname=("lua-$_rockname" "lua53-$_rockname" "lua52-$_rockname" "lua51-$_rockname")
_pkgname=lua-$_rockname
pkgver=0.3
_rockrel=2
-pkgrel=5
+pkgrel=6
pkgdesc='Extended PEG Notation Format (easy grammars for LPeg)'
arch=('i686' 'x86_64')
url="https://siffiejoe.github.com/$_pkgname"
license=('MIT')
_lua_deps=('lpeg')
-makedepends=('lua' 'lua52' 'lua51' 'luarocks')
+makedepends=('lua' 'lua53' 'lua52' 'lua51' 'luarocks')
source=("$_rockname-$pkgver.tar.gz::https://github.com/siffiejoe/$_pkgname/archive/v$pkgver.tar.gz")
sha256sums=('57c0ad1917e45c5677bfed0f6122da2baff98117aba05a5e987a0238600f85f9')
@@ -23,12 +23,19 @@ prepare() {
_package_helper() {
cd "$_pkgname-$pkgver"
- luarocks --lua-version="$1" --tree="$pkgdir/usr/" make --deps-mode=none --no-manifest "$_rockname-scm-0.rockspec"
+ luarocks --lua-version="$1" --tree="$pkgdir/usr/" \
+ make --deps-mode=none --no-manifest "$_rockname-scm-0.rockspec"
}
package_lua-luaepnf() {
depends=('lua' "${_lua_deps[@]/#/lua-}")
provides=("lua-$_luaname")
+ _package_helper 5.4
+}
+
+package_lua53-luaepnf() {
+ depends=('lua53' "${_lua_deps[@]/#/lua53-}")
+ provides=("lua-$_luaname")
_package_helper 5.3
}