summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 17 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 79da25c0e4ff..70e76bbafeae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,31 @@
-# Maintainer: John Sirett <johnsirett3@googlemail.com>
+# Maintainer: Andrew Sun <adsun701@gmail.com>
+# Contributor: <johnsirett3@googlemail.com>
# Contributor: Shacristo <Shacristo at gmail dot com>
# Contributor: Jáchym Barvínek <jachymb@gmail.com>
+
pkgname=lybniz
-pkgver=1.3.2
+pkgver=3.0.4
pkgrel=1
pkgdesc="An easy to use mathematical function graph plotter written in Python and GTK."
-arch=(any)
-url="http://lybniz2.sourceforge.net/index.html"
+arch=('any')
+url="https://github.com/thomasfuhringer/lybniz"
license=('BSD')
-depends=('python2' 'pygtk')
-optdepends=('gnome-python: GNOME Help Support')
-source=(https://downloads.sourceforge.net/project/${pkgname}2/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz)
-md5sums=('0effc8eba87cfa3514ec54157e7f9815')
+depends=('python-gobject' 'hicolor-icon-theme')
+makedepends=('python-setuptools')
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/thomasfuhringer/lybniz/archive/v${pkgver}.tar.gz")
+sha256sums=('725c5274115bd7faad3abb0b7cd2ae8a377b73cbcc8b4e8a6c9522a772976983')
build() {
- cd "$pkgname-$pkgver"
- python2 setup.py build
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py build
}
package() {
- cd "$pkgname-$pkgver"
- python2 setup.py install --root="$pkgdir/" --optimize=1
-
- # Change executable file name on disk
- mv "$pkgdir/usr/bin/lybniz.py" "$pkgdir/usr/bin/lybniz"
- sed -i -e 's/Exec=lybniz.py/Exec=lybniz/' "$pkgdir/usr/share/applications/lybniz.desktop"
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
- # Install license
- install -D -m644 COPYING "${pkgdir}/usr/share/licenses/$pkgname/COPYING"
+ # License
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-# vim:set ts=2 sw=2 et: \ No newline at end of file
+# vim:set ts=2 sw=2 et: