summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..525f57e4e1e6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Arvid Norlander <VorpalBlade (at) users DOT noreply DOT github DOT com>
+pkgname=macutils-git
+pkgver=v2.0b4.r0.58b0225
+pkgrel=1
+pkgdesc="Converting and decompressing some old Macintosh-oriented archive formats"
+arch=(x86_64)
+url="http://fileformats.archiveteam.org/wiki/Macutil"
+license=('GPL')
+makedepends=('git' 'meson')
+source=('macutils::git+https://github.com/VorpalBlade/macutils#branch=modernization')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+build() {
+ cd "$srcdir"
+ arch-meson "${pkgname%-git}" "build"
+ meson compile -C "build"
+}
+
+package() {
+ cd "$srcdir"
+ meson install -C "build" --destdir "$pkgdir"
+}