summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6cab3eca24f3..f84447c2e7ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Lili1228 <aur at lili dot lgbt>
pkgname=martypc
pkgver=0.2.0
-pkgrel=2
+pkgrel=3
pkgdesc='An IBM PC/XT emulator written in Rust'
arch=(x86_64 aarch64)
depends=(alsa-lib libudev.so # explicit
@@ -10,12 +10,19 @@ makedepends=(cargo git)
url="https://github.com/dbalsom/${pkgname}"
license=(MIT)
install=martypc.install
-source=("git+https://github.com/dbalsom/martypc.git#branch=version_$(printf $pkgver | tr '\.' '_')")
+source=(
+ "git+https://github.com/dbalsom/martypc.git#branch=version_$(printf $pkgver | tr '\.' '_')"
+ "config_keyboard_layout.diff"
+)
#source=("${pkgname}-${pkgver}.tgz::https://github.com/dbalsom/${pkgname}/archive/refs/tags/${pkgver}.tar.gz")
-sha512sums=('SKIP')
+sha512sums=(
+'SKIP'
+'a8823b6c266a1ee078ab8a6e0c45f896ba44bf6d84642c9d7c4dfcc3536f15e842598bb09c2232b7b2adc744107277e7f2cf45f6eff2e09c2167a7f75da38bd0'
+)
prepare() {
cd ${pkgname} #-${pkgver}
+ patch -p1 < ../config_keyboard_layout.diff
export RUSTUP_TOOLCHAIN=stable
cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
}